Procedural EQ channels settings unstable [Ticket Open]

My DSP settings are as follows, including 3 parametric equalizers:

I have saved them in a DSP preset.
When i reload that preset, the second parametric equalizer is wrong, being applied to LEFT and RIGHT channels instead of LEFT channel only.

This is annoying as I often switch from one preset to the other.

@support I am sure you can fix this! :slight_smile:

@support: the issue occurs even without reloading DSP Preset. It seems that if I select only channel LEFT for the second filter, it comes back as being applied to LEFT and RIGHT after a couple of plays. Very annoying.
NB: my server is ROCK.

Thanks for the report and sharing this observation you have made with us @alec_eiffel. The insight is appreciated!

Moving forward, I am going to bang on this a little bit to see what I can come up with. I will be sure to share my findings once my testing has completed.


Hi @alec_eiffel ---- I wanted to touch base with you because I have had my test setup running now for about 4 hours and have not encountered the behavior you mentioned in your report. Not matter how many times I quit Roon on the remote or switch zones my DSP engine settings stayed in place as expected.

Are you able to provide some further insight into this behavior? For example do you experience this on all of your remote devices or just some? Does this happen with ALL of your audio zones? Any feedback would be very helpful.

Furthermore, if you reboot not only the core machine but also the remote device and endpoint does this behavior continue to occur?


@eric Thanks for looking at the issue, which is encountered on all remotes (Mac, PC, iOS) and all zones I have tried to applied the preset to. Rebooting the core and remote didn’t fix it, the second parametric EQ kept being applied to left and right instead of left only as defined previously and saved as preset.

What I did today: I removed this second parametric EQ and added a new one with identical parameters, applied to left channel only. Bingo ! Now the preset is saved and restored properly, no more bug. So I guess something funny occured in the descriptors of my previous filters, which was edited quite often.

So my issue is fixed but still I believe there is still an insidious bug within the parametric EQ editor / parameters that can cause errors in channel allocation.

@support: Same issue here. I was going to post a bug report when I saw that it was reported already.

I have the following DSP settings:

When I try to save this to “DSP settings” and load it again, the left channel knob has turned to “Yes”.

1 Like

Hi @Rainer_Muller ---- Thanks for chiming in here and sharing your experience with us. The feedback and insight are very appreciated!

After seeing your report I tried to reproduce this behavior again using my setup (listed below) and am still unable to get this to reproduce :thinking::thinking: Are there any other details you can provide me that make this reproducible? Has your core machine been rebooted since noticing this behavior?

My setup:
Core = NUC w/ROCK (v1.5)(B339)
Remote = MacBook Air w/Roon (v1.5)(B339)


Yes, the computer has been restarted. Roon has been restarted several times, too.

My setup:
Windows 7 PC with Roon Desktop playing from my harddisk.

The bug appears after several edits of the parameters of the given parametric EQ, adding filters, removing filters, changing gains/Q etc…
The only way around is to remove the parametric EQ, create a new one with the same parameters, and never touch it again. This prevent the left channel to reappear unexpectedly.

@Rainer_Muller and @alec_eiffel ---- Thank you both for additional feedback/insight! Rainer, confirming I have seen your PM as well.

I am going to open up a ticket in out system and schedule some testing to see what we can come up with on our end regarding this behavior. Once testing has been completed I will be sure to share our thoughts/findings with you ASAP. Your patience and understanding during this process is appreciated!


1 Like

@Rainer_Muller and @alec_eiffel ---- Thank you both for your patience here. Again, very appreciated!

I just checked on the status of the ticket and can see it is still in our tech team’s queue and as mentioned previously, once all testing has completed I will be sure to update this thread accordingly. In the meantime however, I want to reach out and confirm that you are both still experiencing this behavior on the latest build.


I experienced the same problem about an year ago when I set up parametric eq‘s for left and right channels differently for room correction. When reloading the settings instead of only left or only right both left and right were turned on. I did not report the bug because I switched to HAF filters instead of my own in REW made ones and forgot about this bug. My core runs on an mac mini (late 2014) controlled with Ipads and Iphones and using mostly RAAT on a Rpi3.

I tried to play a bit with DSP/Procedural EQ, adding Parametric EQ filters, changing parameters, allocating channels to either left or right, saving DSP preset, reloading DSP preset…
I could not reproduce the bug. Either it has been fixed or my actions were not the ones to reveal it.
Thanks for looking into it !

Here the left/right problem persists. Same behavior as I described in my first post

One possibly relevant point: I’m on a German OS (Win7) which uses a comma as a decimal separator. In input fields like the ones shown below, I have to enter decimal numbers with a decimal point, but they are shown with a decimal comma. Don’t know how they are saved. Maybe this leads to confusion.

Also, these input fields behave weird on Windows (not on Android). When you change one of them, some others in the same row may lose their values.

And while you’re at it: Could you check your definition of a decibel? When I program a L/R to M/S transformation as described here:

and immediately transform back via L = 0.5 (M+S) and R = 0,5 (M-S), the two filters in succession should do nothing.
The factor 0.5 should translate to -6 dB as described in the cited page.

However, a “do nothing” filter L/R -> M/S -> L/R with this value leads to a reduction in volume. The volume remains unchanged – as it should – if I use -3 dB instead of -6 dB.
So maybe there is a factor 0.5 missing somewhere in the definition of a dB.

All ---- I am pleased to report that our QA team has been able to reproduce this behavior and have submitted a ticket to our DEV team for further investigation.

While I am unable to comment on when this issue will be addressed or when a fix can be expected I will be sure to keep everyone up to date as the team provides me with feedback on their progress. Your continued patience and understanding during this process is very appreciated!

Many thanks!


Hello All,

I wanted to touch base with some good news and let you know that we’ve made some changes in Roon version 1.6 which should address this issue. Please update to the latest Roon Build and let me know how it goes!


1 Like