QNAP Core not recognising new music

Core Machine (Operating system/System info/Roon build number)

QNAP QTS 4.4.2 1320

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Flat network

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Multiple

Description Of Issue

Since build 571, Roon does not recognise new music if I place it in any of the watched folders.

I have three watched folders. One of these folders has very few things in it, so I disabled it and then added it again and this fixes the problem. However, I don’t want to do that for my main folder of 2000+ albums.

I’ve seen a number of reports about this issue - is there a fix in the works?

Current release: QTS 4.4.2.1320 build 20200529
I don’t know if this is related to your issue with Roon, I just post this to make you aware that you are several releases behind.

As an atempt to gather some more information about your setup: Have you already updated your Roon app to the fixed version?

Actually I’m not on 4.4.1 - I’m on 4.4.2.1320 2020529.

All my apps have been updated.

Does this mean that you downloaded and manually installed the fixed version as it has still not materialized itself in the official app store?

Ah okay - the Roononnas app - sorry I misunderstood, I thought you were talking about the remote apps.

No I have not installed the latest version. It looks like it includes a fix for the authorisation bug, which I also had when I first upgraded but do not have anymore. Does it include anything which might fix the directory scanning issue?

Maybe, I can’t tell you if the fixes also affect your issue but if had issues I would make sure to update to the newest version and check again.

Yep fair enough. I will install the updated version and see if it fixes it.