QNAP HDDs not going to sleep - there must be a solution

Good morning community!

I know, it has been discussed before but I want to find a solution :slight_smile:

The HDDs of my QNAP NAS are not going to sleep as long as Roon Server is running on my Windows 7 Server. When Roon Server is not running, the HDDs go to sleep after one hour.

As far as I know this is because Roon is scanning the network for Roon devices, what keeps the NAS awake.

Before my QNAP I had a self-built NAS running FreeNAS / NAS4Free and there it worked without problems. NAS was running and HDDs went to sleep after one hour, tough Roon Server was running. When I started playing a song, the HDDs woke up.

I know there are a lot of people who say: let the HDDs run, its better than doing spin up, spin down constantly. But I am a father of two kids :smiley: I only have time 1 or 2 times a week to listen to some music in the evening. So the NAS is not used 90% of the time…

Could there be any possibility to let the HDDs go to sleep though Roon is running? Maybe blocking the ports Roon is using for finding devices on a QNAP internal firewall? Or is there any possibility to start Roon Server on my Windows 7 machine using Logitech Harmony?

…

…

Any ideas?

Thx and have a great week!

Chris

Stop roon when you are not using it.

Shut down the nas on a schedule and restart as your normal listening patterns dictate

I have sent you a private message with something you could try, I am unsure if it works. If it does, I’ll post it here again and/or include it in the installer.

Hi wizardofoz!

Stopping and starting Roon Server is what I am doing at the moment. But connecting to the Win 7 server with RDP everytime to start and stop is annoying :wink:
Completely shutting down the NAS is a no way solution because of the WAF :smiley:
My wife needs the NAS now and then. And when its not available when she needs it… whoo hoo :smiley:

Chris

I doubt that this will help here because the OP doesn’t run it’s core on the QNAP NAS (Roon not installed on NAS).

Maybe Chris’ solution might help, but perhaps there is no free lunch. Maybe pulling the Ethernet cable of the win 7 box might be quick and easy

I asked about this last year but no solution was available.

My Qnap was constantly active because of Roon. You could hear disk activity every 5 to 10 seconds. I ended up shutting down the machine that ran Roonserver when it wasn’t in use as the Qnap was needed for other purposes. All other applications including JRiver allow the nas to sleep.

I would think a Roon setting to let Roon become inactive between designated hours would work. Perhaps with a manual override if listening during those hours.

But what about the following idea:
what ports does Roon use for RAAT? What if I create a firewall rule in the Windows 7 firewall that blocks these ports to the IP of my NAS? So the ‘scanning activity’ of Roon should not reach the QNAP? Could this work?
Or is RAATServer running on every Roon Endpoint running RoonBridge thats on the network?

KR
Chris

This seems to be more effort than simply shutting down Roon. Roon will also continue to try and fail because of the fw rule and could possibly spin up the CPU with retries.

I vote for letting the drives spin, they will last longer…

Yes and AFAIK also on every active Roon Control. But if you just use your NAS to provide storage, RAAT should not affect the NAS because Roon uses SMB to access the external storage.

I guess that Roon subscribes to OS notifications to get immediate updates about file changes. However, if a watched folder is located on an SMB share, it may not be possible to subscribe to file update notifications. Only SMB 3 and newer supports notifications (for a QNAP NAS: Control Panel | Network & File Services | Win/Mac/NFS check Advanced Options for Microsoft Networking {on mine, Highest SBM version is set to SMB 3 on default}). If Roon is unable to get notifications, it will only detect file changes during a full folder re-scan (time interval is configurable in Roon Settings | Storage).

So disabling the support for SMB 3 on the QNAP in conjunction with a sensible re-scan interval for the watched folder in Roon might allow the disks to spin down for a while.

Disclaimer: Untested as I don’t run such a setup.

Did you install the ROON application on the same DataVolume as your music collection?

@BlackJack I will try this - thx for the tip!

@Anders_Nordahl: No, my NAS is only used for storage. Roon Server is running on a separate Windows machine.
Here is my setup in a little more detail:

Windows 7 Server: Running the Roon Server as it can be downloaded and installed for Windows 64 bit. No audio devices attached here.

QNAP NAS with two RAID5s (4 discs each). It is only used as a NAS. no extra applications are running there. File shares can be accessed via CIFS/SMB. But no fix Network Shares are mapped to them from any Windows machine. I read somewhere that that also may prevent the discs from going to sleep. No audio devices are attached there.

The following Roon Endpoints are available in the network:
Oppo 205 via Ethernet
Allo USBride via Ethernet with Directstream DAC on its USB port.

The following Roon Remotes are used in the network:
iPhone with Roon app
iPad with Roon app

KR
Chris

Is there any update on your case?

Hi! Just got back from holiday yesterday… will play around this week!