QNAP NAS Direct Connected to Meridian 861v8 still drops Roon all the time

Hi there.

Afraid not. In fact I’d argue the direct connection possibly fails less but I haven’t measured scientifically to be honest.


It seems to work as expected for Apple TV and my iMac but the issue is 861.

Challenge is I listen to Apple TV Roon virtually never and IMac limited when in my office so 861 is the go to end point.

Another thing I can test is that hopefully my 818v3 finally arrives after a year and that would be the end point to the 8k’s. I can test with that and see if different and then move my 861 back into the cinema room and see again.

Hi @cmr600,

I would try the router connection once more for both the Core and the Meridian zone.

If the behavior is still occurring with the router connection, I would also try temporarily using a different Core, such as your iMac to verify if the issue is due to any factors regarding your QNAP when in Core mode.

Hi there, thanks for your note.

Tried both again and no difference. The challenge is it’s inconsistent. Sometimes it will play for hours, sometimes less than 10 seconds.

Good idea on the iMac core - will try this when I get home this evening.

Thanks :slight_smile:

1 Like

So I have QNAP looking into this as well and they’re asking if you guys can confirm what port the application uses? As I have surpassed my technical knowledge here I’m hoping that makes sense to you all!

As I’m a QNAP user too, I konw that by default there is no firewall on a QNAP NAS. There might be issues with other software running on the NAS namely Emby and Plex. I don’t know Emby but I run Plex too and if Roon Server and Plex are installed from the store (qpkg) there shouldn’t be a problem.

Note: As I’m using Roon and Plex, all the QNAP multimedia software (servers) are turned off on my QNAP. So I can’t say if there might be undesired interactions if they are active too.

Hi @cmr600,

Did you have a chance to try the iMac Core? Did the same behavior occur there?

Those ports are a starting point, but Roon also uses a few randomly generated ones. Testing to see if the behavior occurs on the iMac would provide a useful data point before diving deeper into the QNAP troubleshooting.

So updates - now have nothing else on the NAS but my music and Roon - everything else off.
Direct connection dropping more and more, likewise switched connection also dropping.
I now have 861v8 and ID41 connected to one end point and an MS200 as another and both keep dropping.
Get’s worse and worse then re-boot NAS and it comes back OK for a little while.
Have done direct cabled connection to the NAS, have moved the direct connection to the switch.
Have removed all power line and all connections to all are now cabled.
Driving me mad - to be honest almost ready after all this time to throw in the towel

If I switch my core to iMac and lose my NAS - (as only allowed one core at once) will that switch back to NAS when I’ve tested this or would I damage / lose the NAS settings etc.?

Hi @cmr600,

You are free to switch between Cores as often as you’d like, the limitation here is one active Roon Core at a time.

No, you shouldn’t lose anything by switching between them, but if you’d like to be extra-cautious, you can also create a Backup of your Roon Database which saves everything from the old database to a backup folder.

Ok so with IMac as core it’s the same if not worse on all meridian end points.

MS200 and 861 both dropping within 15-20 seconds leaving Apple TV and iPhone or Mac still there.

So only Meridian end points.

Hi @cmr600,

Thanks for checking with the iMac Core. This suggests that this is then a networking or endpoint issue.
Can you provide some more information regarding your network setup?

What is the model/manufacturer of your networking gear (router/switches/modem)? How is the ID41 connected to the network, is it connected directly into your router or though a switch/range extender/powerline adapter?

Why would it be switch gear if all other non meridian end points work fine??

Anyway DLink gigabit eithernet switch.

Regular fibre 200mb zuku (kenya) fibre connection and everything wired hard Ethernet into switch / Nas / ID41 / MS200 etc

Other users reported problems in conjunction with switches that support Green Ethernet (EEE, 802.3az) or similar but non-standardized functions (but other, non Meridian gear).
Do you have that switch for longer already (did Roon previously work with your Meridian gear and that switch)? Did you made any changes on your network setup prior to the start of the problems (including changing cables)? Is it possible to disable Green Ethernet (EEE, 802.3az) on selcted /all ports (for testing purpose) on your unspecified DLink switch or do you have another switch (different series and/or brand) at hand to try with?

Hi @cmr600,

Testing the behavior on a different switch is a good idea as @BlackJack mentioned. Some certain switches affect different types of audio gear in a strange way. I would try the unmanaged switch or try connecting one of the Meridian zones directly to the router. Can you give that a shot?

All worked fine with this exact set up for years.
Don’t have another switch and as I live in the middle of Africa on a COVID-19 lock down getting another is a tricky one at the moment!
Let me see what I can look at…

Ahhhhhhh… just checked on the switch…

It’s green!
I have no idea how to try solve but will have a look
Thanks guys!

It can be seen from the link you provided that you can turn-off EEE on the switch using the first DIP switch on the front panel. Please check the current configuration on your switch and set the DIP switches according to your needs (you may have to consult the manual).


The front panel depicted in the manual I linked above looks different from that in the link you provided (no DIP switches!). Therefore it doesn’t include any description about the function of the DIP switches. I leave the link for reference purpose. Does your actual switch have the DIP switches shown on the link you provided? If yes, how are they set now?

My router has to be the one from the ISP here - it’s locked - but are we saying a good try could be all Meridian kit directly into the router (not the switch) and the NAS directly into the router (not switch) would possibly help?
So all M kit / Roon would be direct ethernet wired and then all my other stuff

Interesting. Current set up…