QNAP QTS 4.3.3 Released Today

QNAP QTS 4.3.3 was released today. I just installed it and it seems to be working just fine. Just wanted to let all the QNAP users know.

I adjusted the qpkg already in Oct/Nov 2016 to work with QTS 4.3.x.
As QTS 4.3 is fully 64 bit, there is no requirement to use additional 64-bit libraries for RoonServer on QNAP anymore (as it was required for 4.2.x).

The libraries are still in the package to maintain compatibility with 4.2 (but they will not be used if QTS 4.3 is detected).

So essentially no new qpkg package is needed at this time? I was already successfully running the QTS 4.3.3 beta on the existing package. This is working just fine right now.

The update for QTS 4.3 happened already in November.
If someone has a very early package installed (below 1.0.2), he might need to update it as well.

Any ideas on how to do this. Since QNAP update, I can’t connect to Roon. Version 1.01

You can uninstall and reinstall the current package in the QNAP App Center. Your Roon database won’t be touched in this process.

Is this what I should be seeing

There is now a dedicated new icon to install a qpkg file. It is between the gear icon and the refresh button. :slight_smile:

In the window you can browse to the downloaded qpkg on your harddrive:

Thank you, got it sorted on PC. Chris :sunglasses:

@Chrislayeruk Hi Chris, I always find it better to use a pc or Mac rather than an iPad to administer the Qnap.


Hi Russ, hope your well. Laptop is being repaired (Fan noisy) and old computer is soooo sloooooow but realised this is the way forward. It all works now and seems a bit snappier too…

Cheers, Chris

@chrislayeruk: Please remove the URL from Repository field again. It won’t be of any use there. :slight_smile:

Even though you could install it now with your computer, I tried (out of curiosity) if it can be installed by an iOS device.
Theoretically it should be possible to save it to your iCloud Drive and install it from there. But Safari interprets it as a text file. Have not found a workaround. Same issue if I try to download the Plex qpkg app with iOS.

1 Like

Removed. This all feels so much quicker now. Thanks again.

Just for the record and for the sake of completeness:

It should be possible to install it with an iOS device now. You just need 2 things: Apple iCloud, and a magnifying glass:

(Sorry for german screenshots, I was too lazy to switch my iPhone to english)

  • If you open the qpkg link now with iOS, you can save it to your iCloud Drive (press the “More”-button):

  • Open the web administration of you QNAP, Login, and click on “Desktop-View”.

  • Now you need the magnifying glass: Open the AppCenter and click on the “manual install” button. Click on browse and select the qpkg on your iCloud Drive. Click install.

  • You are done!
1 Like

FYI 4.3.3 was released over 17days ago…

Pretty sure that is not correct. The beta version of 4.3.3 has been available for quite some time now and there have been several iterations but the fully release version became available on 4/17, the day I posted on this. I just checked the QNAP web site and the released version is dated 4/17 as well. Perhaps you were thinking of a beta version?

Yes Beta version