QNAP Roon server app "refuses to connect" error

Hello. Installed the roon server app on my Qnap NAS, but get “xxx.xxx.xxx.xx refuses to connect” (xxx being my NAS ip address). See attached link for the error:

Anyone have a solution before I open a ticket please?


Hello @Christopher_Kelly2 and welcome to the forum.

It looks to me, like you are running a firewall of some sorts on your QNAP. If so, please disable the firewall and try again.

Switch off option to require TLS 1.3

Thank you for the reply. I’m quite new to QNAP. How do I do this please?

This higlighted option below:

Sorry, but that might not help.

There was a similar problem https://community.roonlabs.com/t/error-message-could-not-verify-session-id-on-qnap-when-accepting-https-tls-1-3-only/179532 caused by TLS version but now it seems to work with TLS 1.3 and the error message was slightly different.

Thank you. Yes I tried it, but still the same error message. I think it maybe a problem with the NAS so I’m going to reset for 10 seconds and reinstall the roon app. I’ll let everyone know if it was the NAS.

If you do not run a firewall or other software that is blocking the access, then there is just no service running – that’s the meaning of the message from the OP. You can check if Roon Server is running in the Resource Monitor app. You can also check the event log in the QuLog Center app for anomalies. When you right click on the Roon icon on the desktop of your NAS, you can also choose to “Open in new browser tab”, this way you can see and post the full URL the app tries to connect to.

You can find the QTS documentation at: https://www.qnap.com/go/doc/qts

If you need more help, please provide more information (like for example: Your NAS model, the QTS version, the version of the RoonServer app you’re trying to use, how you installed the app, if there were errors while installing the app, anything else that might be relevant).

It was the QNAP NAS. I had to do a reset and recover. It all works now. Thanks to all who contributed.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.