QNAP Ubuntu 14.04 losing connection

I’m just wondering if anyone has experienced loosing connection to Roonserver installed on a Linux VM, using Virtualization station ? I’m running a QNAP TVS-671.

I’ve essentially, installed Roonserver by the book, including with a static IP. However, at Random times, my remote (on a MAC, via ethernet to the router along with the NAS) just looses contact with RoonServer, and is unable to find it again. While I’m experiencing this, I can ping it’s IP address no problem, and ping from RoonServer to my MAC’s IP. Other remotes, experience the same issue.

Any ideas ?:slight_smile: What port is RoonServer listening on for remote connections, so I can see if it’s responding via telnet ?

No, I haven’t had that problem but it is symptomatic of an IP address conflict. Are you sure your Remote hasn’t got any IP conflicts elsewhere on your network?

IMO, it’s easier to keep track if you let your router assign addresses then use DHCP reservations in your router menu.

Is your static IP outside of your DHCP range?

Thanks for the reply. It can be, yes. Good point. I’ve moved it to outside the DHCP range now, and I’ll see how it behaves. If I still get the same issue, then something else is at play…

If you are in a vm on your qnap, how are your music linked to roon? I got the same problems on a TS-253A in Linux Station as long as i connect the music folder via smb://IP-Adress. The problem went away as soon as i connected the Music Folder on the NAS directly in Linux Station. In a VM this may not possible, but in Linux Station it worked and all connection problems went away.

It’s grabbing the music via the SMB share, yes. Funnily enough, things are stable/reliable at the moment. I’ve set a static IP outside of the DHCP range, and RoonServer has finish analysing all audio. So it may be one of those, or a combination of both that has helped. So I’ll stick with this for now, and give Container station a shot, if I see any issues. The other thing I did, was to install Ubuntu 14.04, instead of the latest version. As that is officially supported by virtualization station. The downside of 14.04/14.10 is that ffmpeg has been taken out of the official repositories, so you need to add a new PPA (there are a few around on the net if you google…).

Unfortunately it’s still unstable. What network settings did you use when installing the Ubuntu image via Linux station (now called Container station) ?. Did you have to setup any special port forwarding for the Roon services ?. As far as I can see, it creates the containers on another internal network range that the one the NAS is actually on…


to use Linux Station you should have installed the latest Container Station. It doesn’t matter if you use ubuntu 14_04 or 16_04 in Linux Station, both work, what you need is to connect your music data from your local nas-volumes in Roon via Local Folder. In Linux Station you can see the local volumes and get the path to it, this is what you have to connect in roon as local folder. So, don’t use Container Station, use Linux-Station to install ubuntu (which depends on Container Station).

Don’t use ffmpeg, use libav-tools, this works in my case.

Linux Station gets its ip from the QNAP System automatically, your room-remotes will see it.


Ahh I see. I didn’t sign up for beta releases, and Linux station is only available from 4.2.1 ;). I’ll install that, and then see how I go with it. Many thanks!

I get the same issue, standalone ubuntu. I doubt its vm related, nor IP related. Its symptom is more like its hanging due to a service or interrupt issue. Just thought that may help.