QTS 4.4.1 no ALSA support

Core Machine (Operating system/System info/Roon build number)

Model: TS-253A
QTS Version: 4.4.1 - Build: 20191010
PKG Version: 2019-06-09
########## Installed RoonServer Version ##########
100600416
1.6 (build 416) stable

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

N/A

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

PCH ALC262 Analog (ALSA onboard)
Topping D50 (USB)

Description Of Issue

After upgrading QTS from 4.3.6 to 4.4.1 Roon doesn’t see any audio devices. Multimedia Console is enabled, Library is fine (using Android app), Database is at ~15% (USB stick).
Basically the issue is that RAAT doesn’t detect ALSA support anymore, so QTS must have changed something in the audio backend:

Info: Starting RAATServer v1.6 (build 416) stable on linuxx64
Warn: [RAATServer] detected no ALSA support

@crieke I figure you’re the best person to ask, have you had a chance to test out the app on QTS 4.4?

Best regards and thanks for making it possible to run Roon even on our NAS boxes :slight_smile:

I have QTS 4.4.1 installed on the TVS-471 and had no issue so far with ALSA in Roon Server.
Multimedia Console was installed and all Outputs were identified by Roon.
I will check on my backup device with a clean install of QTS 4.4.1.

1 Like

:raised_hands: thank you for the blazing fast reply!

Just to be clear, the same Roon Server ran flawlessly on 4.3.6 :confused:

Let me know if I can help with any logs or live debugging, I’m at home with linux.

FYI:

Installed QTS Apps: netmgr,ResourceMonitor,Qboost,RoonServer,NotificationCenter,SSDLaboratory,MultimediaConsole,container-station,LicenseCenter,QcloudSSLCertificate,

Hi @diftri,
I tried with 2 anapaest, both on QTS 4.4.1 and was not able to reproduce this. The second qnap has also been fully wiped and reset to factory defaults.
Could there be an issue with the installation of QTS 4.4.1 when you performed the update?
Are you familiar with ssh?

Thanks for double checking! The installation went fine, like any other update, no noticeable issues (other than Roon :confused:) . But obviously something went wrong.

Yes sir, familiar with ssh since Slackware 9 :slight_smile:

Can you run the following command to check for the location of the libasound library

sudo find / -name "libasound.*"

and paste the output in a reply here?

# find / -type f -name "libasound.*"                     
/share/CE_CACHEDEV1_DATA/.qpkg/RoonServer/lib64/libasound.so.2

# ls -l /share/CE_CACHEDEV1_DATA/.qpkg/RoonServer/lib64/libasound.so.2       
-rw-r--r-- 1 admin administrators 1478902 2019-06-09 14:31 /share/CE_CACHEDEV1_DATA/.qpkg/RoonServer/lib64/libasound.so.2

Thanks. The file seems to be missing. (The one in the Roon Server directory can be ignored.

Which qnap model are you using? I will check its QTS firmware file then.

This is the output of the same command on the TVS-473:

/usr/lib/libasound.so.2
/usr/lib/libasound.so.2.0.0
/home/httpd/cgi-bin/hwtest/util/libasound.so.2.0.0
/share/CACHEDEV1_DATA/.qpkg/RoonServer/lib64/libasound.so.2
/mnt/ext/opt/bluetooth/usr/lib/libasound.so.2.0.0
1 Like

Yeah, makes sense, thanks for the info!

Model and some more info are in my first post^: TS-253A

Sorry, I must have missed this, as I was writing on the phone… :wink:

I downloaded the QTS system for the TS-253A and extracted its files. the libasound is still available as part of the system’s “bluetooth” component (it was the same on QTS 4.3.x):

But I managed to get into the same situation for a short time today, after I swapped all my hdd for new drives and set up the device again. But now everything is back to normal. I will check, if I can reproduce this somehow…

Can you try to do a manual firmware update with the same buildnumber again?
Just download the firmware file at the QNAP Download page and select the tab “Firmware Update” (instead of “Live update”), Browse to your downloaded file and click “Update System”.

Good to know you were at least able to reproduce it.
Actually tried manual update yesterday, first without unlocking my volume, then with the volume unlocked.

Think I found the issue, wouldn’t have found it without your tip about bluetooth, so this is the bluetooth init script: https://linx.li/jsn29gwy.sh

I think the script gets executed before the volume is unlocked and basically nukes all of ALSA/bluetooth, check the bt_uninstall function on line 177…

SSH to QNAP and run as root:

# /etc/init.d/bluetooth.sh start
# find / -type f -name "libasound*"
/share/CE_CACHEDEV1_DATA/.qpkg/RoonServer/lib64/libasound.so.2
/mnt/ext/opt/bluetooth/usr/lib/alsa-lib/libasound_module_pcm_bluetooth.so
/mnt/ext/opt/bluetooth/usr/lib/libasound.so.2.0.0

As a result Roon finally sees the main zone that was already configured with the onboard audio, but Configure Roon OS devices still loads infinitely and I can’t actually configure any zone on the NAS.

Do you have some kind of unusual volume setup on your qnap? Just trying to understand, why the bluetooth.sh script might fail and your volume might not be unlocked at that point.
I’d have assumed that qnap triggers this script after the volume is ready.