Quick access to local library [Solution - Focus Bookmark]

I’ve been using Roon for a short while now after becoming a lifetime member and it’s become my software of choice for managing my music collection. I was wondering though if it’s possible in a future software update to add under browse on the dropdown list a selection for “My Library”, or the like, that would provide quick access to albums and tracks stored on my local hard drive.

Thanks for a great software product. It’s quite versatile and fun to use.


I’m assuming you mean local library vs streamed sources (Tidal, Qobuz). The method I use is to tag every album I add to my library from Qobuz. Simple enough then to focus on Qobuz or not Qobuz.

You could also set a bookmark using Focus.
From the Album view, select Focus>Inspector>Storage Locations and click the Local storage location you want. Then Bookmark this location. Then whenever you want local storage view only, click on the Bookmark.
The advantage of Bookmarked views is they are dynamic. So whenever you add music to the local storage location you will still find it.


Doh! Forgot that was in there.

Thanks, fellow Roon users, for your suggestions to get quick access to the music library on my local drive.

I had originally thought about the tagging method for every album but with over 800 it seemed rather cumbersome.

The focus-with-bookmark routine suggestion, though, does exactly what’s needed. Now my local library is only a couple of clicks away. Great!

Obviously I have much more to learn about Roon. The help is appreciated.


Another way to do the same thing is Focus>Format>Tidal which will show all Tidal albums, then click on the green +Tidal which will turn to pink -Tidal showing everything which is NOT a Tidal album - in my case (with only Tidal and no Qobuz) that’s the local files.


Wow! Another great idea of how to use the Focus feature. I can really put this idea to good use, too.

I never knew Focus could be used in so many ways, but I do now.

Thanks for all the help from you experienced users. I have now lots of new ways to use Roon to manage my music libraries.


Yep, using focus for this is much better than tagging as they have to be maintained manually where this is automatic (and similarly for Qobuz).

1 Like

I’ve been using this Focus strategy for a while but recently discovered a (slight) problem with it. If you have supplemented your personal collection with higher-resolution (eg. 96/24) Qobuz/Tidal versions of the same album, then the original CD-quality (in my case) versions do NOT show up once you exclude the streaming versions with Focus.

Is this a bug or a feature? :slight_smile: Would be nice if Focus would ungroup those versions when necessary for exclusion…

Hmmm, that sounds like it might be a bug.
It is true that Roon will default to the highest resolution as the Primary version available in your library. You can over ride that default by selecting another version as the Primary Version.
But I can reproduce this problem. I had Daniel Martin Moore’s “In the Cool of the Day” in my local collection as an AAC (257 Kbps) file. When I use the bookmark it is there. But I added the 16 bit, 44 kHz FLAC file to my library and then used the bookmark and the album was gone. Neither was there.
A solution is to make the lower resolution file the Primary Version. You may need to go back and redesignate the lower resolution version as Primary, as adding the newer higher resolution file will make it Primary. When I went back and did this, the original version is now present with the Bookmark.
It seems like a flaw to me. @Carl, any thoughts here?

@David_Roberts I could not replicate your issue (using the Focus tool for +/- Tidal) in my library with a number of albums that I have both as CD rips at 16/44 in my own collection and as MQA in Tidal.

I have two copies. Local AAC 257 Kbps file and a 16bit 44 kHz FLAC file in Qobuz.
No filter, I see the local file and the Qobuz albums in my Library. The FLAC file is set to Primary Version.
I now do Focus>Format>‘Not Qobuz’ and that album does not show up!
I make the Local low resolution file Primary Version and do Focus>Format>‘Not Qobuz’ and now the album shows up. So at least as I’m doing it, it doesn’t seem to be the way you use Focus, but whether the Primary Version is in the filter.
If I take two albums, one Tidal in 16 bit (Mac Miller, ‘The Divine Feminine’) and one local in 24 bit set as the Primary Version with no filter both show up.
If I do Focus>Inspector>‘Not Local Storage’, the album doesn’t show up again. If I make the lower resolution Tidal album the Primary Version, it does show up with this Focus Filter.
So it seems to me that regardless of how you use Focus, either by selecting a location, or “not selecting” the streaming version, if the album isn’t the Primary Version of two duplicates, it does not show up.

Aha! The solution is Settings>General>Show Hidden Tracks and Albums needs to be set to “On”.
This switch controls how things like Duplicates are shown. By default, “OFF” will only show the Primary Version of an album. Apparently, when the switch is set “OFF” like this it will not display the non Primary Version even if it is no longer a duplicate in a selected view. Thus, this selection will not show the album. When the switch is set “ON” the non Primary version will now show.
This is probably why @Rockhound got a different result when he looked at the problem.
So, I guess this is technically not a bug, but there are negative collateral consequences in some situations.

1 Like

Duh! Thanks for figuring that out.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.