RAAT and 32 bit

With modern 32 bit DACs, would it not be better if the internal calculated double values (after volume adjustment, convolution, PEQ, etc) was converted to 32 bit instead of 24 bit before sending to the DAC? Or at least an option to do so.

Setting aside that no 32 bit DACs possess even remotely close to 32 bit resolution, just 32 bit processing, how many 32 bit DACs actually can accept 32 bit input? RAAT is not the bottleneck, as it certainly can transport 32 bit to HQPlayer.


I don’t know about accepts, but seems all new DAC brag about resolution up to 32 bit/768 khz.

I am not that familiar with what actually happens inside the DAC, but it feels like rounding to 32 bit would result in better SQ, and also faster execution (less bitwise ands, shift lefts etc).

Roon’s DSP engine already does this–when converting down from 64bit for the DAC, it always goes to the widest format your DAC’s driver claims to accept.

24bits of precision gets you 144dB of dynamic range–much more than any room you might be listening in, the resolution of your ears, or the resolution of real life transducers or amplifiers. Yes, Roon supports passing on 32bit data too, but more for completeness’ sake than because there is an actual sound quality improvement associated with it.

Adding to the complexity, a lot of DACs use 32bit wide sample sizes when playing narrower samples–so even when playing 16 or 24 bits, the DAC is treating it like a 32bit signal.

Ok, I just saw that the output to my DAC is 24 bit, but at least the DAC chips (ESS 9038) is supposed to support 32 bit. Maybe limit is in XMOS?

On Windows, I tend to suspect driver first. But it could be how the XMOS chip is portraying the formats to the driver, too.

I have the new Pro-Ject S2 DAC, but I am not going to bother John about this, I think I have given the poor guy enough stress as it is! :slight_smile:

If you haven’t yet, try flipping on this setting and seeing if it’s different:

I have that on already, if I don’t use that I get max 192 khz and DSD64. I tried turning it off but still 24 bit. But I have some other smaller issues as well, like how I can’t up-sample to 768 khz or use DSD512.

I use the supplied UNI project drivers, version 1.61.4, Windows 10. How come it works for you?

I don’t actually have the right driver for the current S2…gotta get that sorted. My driver matches a pre-prod version of the product. So I have no idea what does/doesn’t work for me :slight_smile:

Sounds like cheating :slight_smile:
But others with same drivers as me can up-sample to 768 khz, and play DSD512. This in itself is not a big deal, but I can’t help wonder whats wrong with my installation. USB cables? Other drivers that somehow interact?

Maybe they are using the ASIO driver.

Don’t think there was any ASIO driver with the DAC, do you download them from somewhere? Or enable them with some setting? (I am a 100% complete ASIO noob :slight_smile: )

Usually there’s just one installer for both drivers. Check Settings->Audio and look for something related to Pro-Ject that says ASIO underneath it…

Mine looks like this:

Cheers, that worked, but I lost the new fancy Pro-Ject icon! Got 32 bit output for PCM now! Btw, how many DACs do you have connected? Looks like a bunch of them! :hushed:

ASIO drivers show up even when the DAC isn’t there…I’ve got about 50-75 of them installed :slight_smile:

Yah, we can’t do device ID through ASIO–working on a way to manually override that, but it’s not ready yet.