RAAT to UPnP Bridge (for my Devialet Phantom Speakers)

One option is a Phantom Dialog, which has an optical interface and ethernet jack.

Another is a Raspberry Pi with an optical HAT and Roon Bridge. Plug it into ethernet, and you can connect it directly to either speaker’s optical input and stream through RAAT.

I’ve used both with Phantoms, and both work fine. For what it’s worth, I don’t think that either is a real improvement over 16-bit AirPlay.

1 Like

There is nothing to bridge RAAT to upnp. There is a software bridge that can be used that exposes upnp renderers as Squeezeboxes which Roon will see and supports up to 192/24 but it streams using Squeezebox protocol not RAAT. This is called lms2upnp and can be installed and run on a pc a lot use this to get Roon to non Roon Ready devices… Do the Devialets expose themselves as a seperate upnp renderer per speaker or one for both. As you would need to ensure both are setup and added to Roon and then would likely need to use DSP to filter left/right to the correct speaker.

There is also a hardware box UPNP bridge made by SGC that does the same as the software but is not cheap. You can get this from Vortexbox in the UK or Small Green Computers in the US but it wil only work with one device so if both speakers are seperate upnp renderers it won’t work.

The other option is a seperate streamer with optical out to the speakers.

3 Likes

I used a Raspberry Pi 4 with HifiberryOS and a HiFiBerry Digi+ Pro “hat” (a board for the pi) to stream Roon to the paired Phantoms using optical. Works like a charm and is super easy. The Pi itself is small and cheap, and it’s been very reliable for me. Just make sure you get a good quality opitcal cable and connect it to either of your paired Phantoms.

Hi Crystal Gipsy, thank you very much with the hint to the Sonore UPnP Bridge.
I was already frustrated, because my HiFi device seller told me, that nothing exists like this.

Now I just need to find out if it works with my stereo pair of Devialet Phantom. One of them has the name of the zone (diningroom) in my home network.

So I guess this one is somehow the master for stereo…

I keep on searching, to find out if my guess is right.

Hi amg, I do have a Dialog. I guess it should be connected via Toslink to an Toslink/ HDMI adaptor to my Nucleus…

Actually I altready tried this kind of connection with my cd player. It worked, but I recognized small gaps in the sound. Maybe it is because Dialog and Nucleus are on the same Powerline via Ethernet…,

And I could not test 24Bit with my CD player.

I need to check this as well…

I’m not sure anyone ever got the Sonore to work with Phantoms

If you have Ethernet, use that. Much more reliable than the Phantom’s power line networking, especially with high bitrates.

I have a Dialog down in the basement connected via optical to a Mac running Roon Server. The Dialog and Phantoms (two floors up) are all on hardwired Ethernet. Works great.

I’ve used this. It works very well feeding SPDIF into my Devialet Phantom. I only have one speaker.

The small gaps in the sound is a bug in the Devialet software. It’s been there for years, but Devialet hasn’t fixed it yet. If you use an optical input on a Phantom there’s no bug.

Hi Andrew, thank you for your support.

I understood, that your roon core device is connected via Toslink to the Dialog.

In my case, I made an test with connecting Nucleus (HDMI) over a HDMI to Toslink splitter and then with Toslink into my Dialog.
With this setup I recognized small gaps in the sound.
Don‘t know if I used the wrong HDMI/Toslink splitter.

One question to your setup. Are you able with this (Mac connected via optical to Dialog) to listen to 24Bit Audio on your Phantoms?

As ragwo said above, the gaps are a bug in the Devialet DIalog firmware. It’s not going to be fixed now that Devialet have made the Dialog obsolete.

The way to do this is to use a Raspberry Pi with an optical out hat like the Hifiberry Digi connected to an optical input on any one of the Phantoms. There is no difference in the sound compared to the lms2upnp software bridge.

The hardware box made by SGC is nothing but the lms2upnp software running on an SBC. The RPi can support upto 192/24 which is the maximum the Phantoms can manage anyway. The SGC haredware bridge is quite expensive too.

I have been running an RPi with a Hifiberry Digi hat for years with no issues. I have also been using wifi for the RPi and as long as you have decent wifi it works well as 192/24 does not use a huge amount of bandwith.

Forget the upnp - the software bridge is flaky for this use case. It’s also a pain to setup correcty. And also forget about the Dialog - it’s useless too.

1 Like

Thank you all for your feedback. I really appreciate.

From a similar post 1/2 year ago (thank you Ged) I figured out…

I have the same setup:

  • Running Roon Core on Nucleus
  • 2 Devialet Phantom in Stereo over Ethernet cable
  • 1 Dialog over Ethernet cable (Currently Toslink to my CD Player)
  • Devialet DOS2 Software
  • Goal is to run High Resolution Audio over Roon with the Phantom Speakers (24Bit and more)

May I summarize:

  • Hard to connect Sonore UPnP Bridge to Devialet Phantom
  • similar to Sonore but cheaper is lms2upnp software bridge
  • Direct Toslink to Phantoms work better than direct Toslink to Dialog
  • Solution 1: Use Mutec MC3 + USB between Nucleus and Phantom (or Dialog?). USB on Nucleus. Toslink on Phantom (or Dialog?)
  • Solution 2: Primare NP5 connected via Toslink to Phantom
  • solution 3: use a Raspberry Pi + Hifiberry Digi and connect it direct via Optical cable (Toslink) to one of the Phantom.
    One RPi + Hifi Berry Digi for the stereo pair is enough. Unfortunately I have no experience with Raspberry Pi … I guess the Raspberry is via Ethernet cable or WiFi in the home network and it should have an digital optical output…

In one answer to my post, I get the recommendation simply to connect Nucleus via Toslink to Dialog for playing High Resolution Audio.

Maybe I will try this before the Mutec.

Hope that Devialet will enable RAAT on the Phantom too. The Devialet Expert at least is Roon Ready. But this is another story…

Hi Mehul, thank you for your feedback.

Unfortunately I have no experience with Raspberry Pis. I fear, that I need first to learn how to setup OS on Raspberry Pis before I can solve my Roon to Phantom topic…

I understood that each of my Phantoms need to be connected to their own Raspberry Pi.

My 2 Phantoms are standing in the same room and are playing in stereo.
Would it be possible to play them in stereo too over the setup with the Raspberry Pis?

And how is Roon recognizing the RPis in the Audio Setup?

Hubert

The RPi is relatively easy to setup. A few minutes on google and you should be able to find a guide.

You only need 1 RPI/Hifiberry Digi combo for the stereo pair of Phantoms. Connect it to the optical input of either of the Phantoms. You can then play in stereo. You’ll need to activate the optical input in the Spark app (if you;re still on DOS1) or in the Devialet app (on DOS 2)

Roon sees the RoonBridge software on the Raspberry Pi - not the Phantoms directly. As soon as you install the Roon Bridge Software, the Roon server on your Nucleus will “see” it.

Yes, no issues with 24-bit through the Dialog’s optical input.

Yes, the Dialog’s optical input was wonky in the past, but it seems to work fine with DOS2. I’ve been using it for months now, with no issue.

1 Like

My solution…more expensive than the solutions described so far…Primare NP5 connected via Toslink to the Phantom Gold…I was willing to pay a bit more because I wanted to also (besides Roon 24/192) add Chromecast, AirPlay2, etc, all in one box…basically “forget” the Devialet App always setup for Optical (max volume at 60%) and I control the volume directly with Roon or AppleTV remote or by voice with Chromecast/Google Home…the Primare automatically shifts the source…this solution it’s not glitch free but works pretty well…

One problem that I have, still trying to work out where is the problem…if I setup my NP5 to max quality 24/192 from time to time the Phantom reports “no cable is connected”, when clearly it’s…the dame doesn’t happen if I stick to 24/96… Phantom support is blaming on the quality of the cable, but I’m not sure.(several people tell me they use pretty vanilla cables to transport hires music with no problems)…already tried two types of cables and the same problem…I order on-line a Lifatec Toslink cable, if with that one doesn’t work, no cable will work so…any experience/recommendations in this space?

Regarding the cable, I’m using a $2 3m toslink cable from my RPI to a Phantom streaming 24/192 with no problems at all. Still on DOS1 though.

The Dialog crackle was an issue for me until I updated to DOS2, which seemed to solve it. That said, in an effort to simplify things I removed it from the mix.

Although I don’t have Nucleus, I do have a ROCK currently running as both core and endpoint with a Meridian Explorer doing the USB to 3.5mm Toslink conversion into the Phantom. Maybe an odd choice, but the Meridian was lying around and the headphone jack on it doubles as an optical out if you have a 3.5mm optical cable.

I do still have to use the devialet app for volume. Not sure if DOS2 has a fixed output optical mode like DOS1 did but that might allow volume attenuation to occur outside of the Phantom without loss of SQ.

@ragwo thank you for the feedback…I’m in DOS2… :unamused: …once again, I’m pretty sure it’s not a cable related, it must be a Phantom with a bad Toslink connector or something…