Rasberry Pi/ Qutest won't work with Curious USB Cable

I just received a Chord Qutest, and having read suggestions I picked up a Curious USB cable to go with it. I’m trying to use my Rasberry Pi as the streamer going into the Qutest via the Curious USB, however whenever I plug in the Curious USB it won’t show up as a device in Roon most of the time. Occasionally it shows up momentarily but then has difficulty connecting. However, when I use the USB that came with the Qutest it works fine. Additionally, if I plug the Curious into my MacBook pro and then to the Qutest, the Qutest shows up immediately, so it’s something to with the Rasberry Pi in the chain.

Any ideas?

Just use a standards compliant USB cable, which works, and forget about these crazy voodooo cables.

1 Like

Might do that, although I already have this cable so would love to make it work.

I would suggest you do basic resistance checks to make sure there are not any wiring errors/issues with the Curious cables. If purchased new return them to the vendor for a refund or exchange…

1 Like

Like @Digital_Dude says, conduct a test on the cable, resistance and continuity (some multimeters do both at the same time). Most curious though (no pun intended) is the USB that came with the Quest works with your Mac, it’d suggest not a cable fault. Sounds silly, did you fully insert both ends of the Curious cable? Did you try all RPi USB ports?

Also, not that it should affect it, what power block are you using with the RPi?

I owned a Qutest a few months back.
I had zero problems with any USB cable I tried connecting to a Sonore Ultrarendu.
This included el cheapo printer cable, Audioquest Carbon, Audioquest Diamond, Pangea, Straight Wire etc.

I think there maybe a problem with the Pi4

I’ve had a Qutest for a couple of years now and have had no issues with a couple of usb cables, a couple of laptops > Qutest, servers > Qutest and network transports > Qutest all over USB… As I understand it, the Qutest has quite the galvanic isolation and secret sauce to reduce noise ingress thanks to Rob Watts… I would look to the cable first then the RPi transport…

The cable works immediately when connected to my Mac Book Pro, yet definitely seems to not work when plugged into the pi. I’ve also tried to play through Spotify using RoPiee XL and with the Curious cable, no sound, but it recognizes the RoPiee (since Spotify Connect doesn’t need to see a DAC) if I change cables it works, most of the time.

i also have a curious cable and it does not work with my rpi4, doesn’t show my dac

There is a related thread on another forum (also with a Qutest):



Not the outcome that I was hoping for but alas Curious got back to me and their assessment is that their cable is just incompatible with the RPi platform.

While at first I was having intermittent issues with the stock cable as well, I re loaded RoPieee and it I consistently get a good connection with the stock cable. So, yeah, does seem like the cable doesn’t work with Rasberry Pi. I have an email out to Curious, but sounds like they’ll tell me the same thing as you @Anthony_B .

Well, you may win and it looks like the stock cable is the way for now!

A not so standard, standard USB cable… Wonder what voodoo lies within??? You might try and Ohm the cable to see how far out of spec it might be…

1 Like

I think you’ve got your answer right there.

1 Like

I’m having same issue with a curious evolved usb with rasberry pi cable works perfect from nuc to dac but not when rasberry is in chain as a strramer

Alex yes mine won’t work so I will use a audioquest coffee usb actually sounds better with the pi with ropieee than just using intel nuc and curious directly to Hegel h590 dac

So you are limited to volumio ?

I just skimmed Curious’ website and read “Our Story”.
Purely empirical cable design without any technical scrutiny - and people wonder about failing USB handshaking?
And off topic:
If you use their XLR balanced cables, sporting silver plated contacts, make sure you regularly re-plug the connectors to clean off the buildup of tarnish.

1 Like

Hi Andy, just saw your post, no Volumio is my least favourite platform.
I predominately use only ropieee and occasionally for fun I will build an LMS server.
I have the curious cables were they need to be (Innuos MK3 mini server, Innuos PSU, into an OPPO HA-1, everything sounds very good so I have stopped tinkering.

Thanks for following up!

Best, Alex