Rasp Pi with HifiBerry Digi+ Pro does not see my external Mytek dac

I have a Mytek Liberty attached to the Raspberry pi with USB and dont get any sound.
HifiBeery Digi+ Pro i see in Roon and its Roon Ready and all is purple.
As a Core i have a NUC i8. Am i doing something wrong
Do i need a COAX cable to have sound

You don’t need to use coax. I have the same set-up, Pi connected with USB to a Liberty DAC, and it works great. Can you see the Liberty in the Roon UI? Are you also using the Digi+ Pro hat with the same Pi? If so, what is the Pro connected to? Can you see that connection? Are you running RoPieee on the Pi?

My guess is that either (1) having a hat on the Pi is confusing things, or (2) you need to work on the Pi’s operating system a bit more.

I am running HifiBerry OS . And yes i am using the Digi Pro hat with the same Pi.
I can not see the Liberty in roon unless i connect it too my NUC Core.
The pro is only connected by USB directly to my Mytek dac.

And, are you running RoPieee on your Pi? Or something else, like VolumeIO?

Nope. i am running Hifiberry OS only. Is that the problem ?

The HiFiBerry Digi+ Pro only has two outputs, both S/PDIF, one coax, the other optical. So I don’t understand when you say,

You can’t connect the Pro hat with USB, only with S/PDIF. Is anything connected to the outputs of the Pro hat?

Probably. I suspect it only looks at the Pro hat, and you don’t have anything connected to those outputs.

I would use RoPieee instead of HiFiBerry OS. I know it supports HiFiBerry products.

I did try the optical from the hat to the Liberty but still nothing. So what i need is a coax cable going from 1 to 2 ends of the Mytek and an optical

Or, you could just take the hat off. Connect the Liberty DAC via USB to the Pi. Put RoPieee on the Pi. And you’re done. That’s how I connect my Liberty.

Actually, I think all you need is to replace HiFiBerryOS with RoPieee. I’d bet it would then see the USB connection as well as the Digi+ Pro.

Thx Bill i give this a try and you hear from me. actualy i am kind of a nerd when it comes to the raspberry.

Sure, no problem.

I have replaced hifiberry for ropiee and indeed i can use the Mytek dac. Why does the signalpath say full decoder for the Mytek. Ore is this normal within Roon

I am asking myself 1thing. Just before the purchase of the raspberry i had my Mytek connected straight on the Nuc core with the same result. Mytek Full decoder. Is the Raspberry of any use !

It’s mainly if you want the DAC farther away from your NUC than the USB cable will reach. Then you can use Ethernet or WiFi to the Pi to get the bits to the DAC. Some people who are also afraid of ghosts will tell you that electrical interference can travel across the cable from the NUC to the DAC, but there’s precious little evidence of that happening with the modern equipment you’ve got.

So why did you buy it?

There are settings in both Roon and the Liberty itself which can affect what Roon thinks about the DAC. Where do you see “full decoder”?

thx for explaining. I see Full decoder in the signal path and the colour is light blue. I have MQA on the mytek so i quess all is fine.


Except it says that you are playing through a “MOON NEO ACE”. That’s not a Mytek Liberty DAC.

Here’s what my signal path looks like. My Liberty endpoint is called “Liberty”, and my Pi is called “Living Room Endpoint”.


It was just an example. I do have a liberty dac

What do i have to choose. The mytek gives me the right path. I have a Marantz Amp and the bottom where you have the Liberty DAC in the signal path.
When i change zone too the Pi i dont see the Mytek in the signal path