Raspberry PI 4/HifiBerry DAC+ and 192khz Files

I am seeing an issue when playing 192Khz FLAC files. Roon interface shows the file as playing, but the Ropieee endpoint with the Hifiberry DAC+ is silent. This occurs if the song playing before the 192 song, is any file at a lower resolution. If you skip to another 196 file it remains silent. Playing any file lower than 192 results in audio being audible again. This can be repeated at will. This occurs on 3 of the exact same Ropieee builds (these are brand new builds):

Raspberry Pi 4 Model B
HifiBerry DAC+
16GB San Disk Ultra DSHC
RoPieee Version 2.464

I have another Ropieee endpoint built on a Pi3b - with everything else the same (Hifiberry DAC+, same SD card, same case etc) and it plays through fine. About 6 months ago this Pi3 build exhibited the same issue - so I set the highest resolution to 96Khz and it worked no issues. About 2 months ago (timing is fuzzy), I set it back to 192 and it worked without issue and has since and still does. During the same time frame I had 2 other Pi3’s exactly the same build only using a HifiBerry Digi+ - they played all files with no issue (and still do).

So at this point all 3 Pi3 builds play all files with no issue, but the 3 new Pi4 with DAC+ builds struggle with the 192 FLAC’s (as the Pi3 with the DAC+ used to a while back).

The Roon core is a Nucleus+. This was added last Friday. The core was moved over from a Windows 10 Pro machine that had been operating for about 14 months (backed up and restored to the Nucleus+). The Pi3’s played through all files on both Core setups.

As well, I have changed the DSP and zone options around (cross fade, volume leveling etc) - no change either way for any of these settings. Pi4’s currently won’t play through 192 FLAC’s.

It’s a pretty weird and very small issue :slight_smile: These RoPieee builds are unbelievable reliable. The simple fix for now is to set the Pi4’s to 96Khz max. I mostly find it interesting that the problem that existed in the older Pi3’s that went away has show up now again in the new Pi4’s - and am curious if anyone else has experienced this. I must be missing some small detail…

Thanks all!


I just gave that a try - but the results are the same. I should also note that I was able to play using USB to a separate DAC without issue. It’s seems to be limited to the DAC+ HAT at this stage on these PI4’s.

Thanks for the suggestion.

1 Like

When I used a DAC+ many moons ago never had this issue with switching rates. My Amp2 which is based on DAC+ inside also works fine all the time whatever I send to it.

Both of my HiFiBerry Dac+ HATs (one on a Pi 4 and one on a Pi3) max out at 96Khz on the optical output. Apparently, 192Khz capability is affected by the optical cable and the receiving end. Can you try coax??

I currently have 2 Pi3’s with Digi+ HAT’s - both play 192Khz over an optical connection without issue. Perhaps your issue is with the DAC your using not handling 192 over its optical input?

It is the DAC+ HAT’s on PI4’s that have the issue with outputting audio when playing 192 FLAC’s. The PI3 with a DAC+ currently plays 192 with no issue.

I am currently having the same problem but i have no out put from the pi.
The hfi berry optical out is lit the input on my audiolab m-dac+ shows input as pcm 44.1
ipad shows music is playing, so whats going on.
Please help

For the sake of clarity - the issue I’m seeing is only with the DAC+ HAT on PI4’s. DAC+ outputs analog audio. Most reply’s here so far have referenced the Digi+ HAT that outputs a digital stream via SPDIF or Optical. In my case I have no issues with the Digi+ HAT. Only the DAC+ on PI4’s.


Same here, had my ROPIEEE PI4 DAC+HAT playing once when I got it, now it only works up to 96kHz. Very odd…

Solved it: Found out that for whatever reason in ROON that “Private Zone” tab was set, removed it and now up to 192kHz plays again! You’ll find that in AUDIO → Setup (“name of your DAC+”)

1 Like