Raspberry pi endpoint doesn't show up

I just setup a Roon Core (in my 14 day trial period) on a Windows 7 laptop. Roon runs fine and has discovered some endpoints on my network, but not the Raspberry pi 3.

Both the laptop and RPi are using wired ethernet connections. Both are plugged into the same switch.

The RPi has a HiFiBerry DAC+. I downloaded the RPi image for Roon from the HiFiBerry website and using diskimager I imaged an 8GB microSD card. The RPi’s green led activity light flickers & blinks constantly, so I know it’s not locked up. I should mention that I am very familiar with the RPi, so I know how to image and load a RPi.

When I go to the Audio menu and look at the Network section, the RPi is not there.
I’ve rebooted the laptop several times - no help.
I’ve rebooted the RPi several times - no help.

Are there other RPi images out there I can try? Does dietpi have a Roon option?

Yes, you can use DietPi. Or, you can use the purpose-designed RoPieee.

May I suggest that you try RoPieee?

I have RPi 3B+ and HiFiBerry Digi+ Pro HAT. and I got these and used them for my trial, and I choose RoPieee and followed the instructions, and it worked first time, and is still working just great. Support direct from within this forum for RoPieee is excellent, and speedy.

Hi @Thomas_Prossima1,

Can you describe your networking setup a bit? What is model of router and switches are you using? How is each device connected?

Are you able to see the RPi over the network outside of Roon?

Thanks everyone. I’ll give RoPieee a try :grinning:

Well, I don’t know what’s going on here. RoPieee is a complete bust. I downloaded the RoPieee RPi software from ropieee.org. I flashed it with Etcher (validation passed). I power up the RPi. The red LED is on and immediatley the green LED flashes 7 times, pauses, 7 times, pauses, 7 times, etc. - forever. I’ve let it sit there for as long as 20 minutes and the green LED does the same thing the entire time. What’s going on? I assume the 7 flashes means something? Eventually isn’t it supposed to have a steady slow blink.

I’ve tried 2 different RPi 3B+
I’ve tired 2 different Sandisk ultra 32GB cards
I’ve tried 2 different power supplies (one 2.5A and one 5A)
I’ve tried it with the HiFiBerry DAC+ installed and without (just the RPi).
I’ve re-downloaded the RoPieee image and re-flashed (standard, not XL).

Still get the infinite 7 green LED flash.
The ethernet cable is always plugged in, but the “connection” lights never come on. So, this tells me the installation hasn’t even progressed far enough to turn on the ethernet port.

If you’re up to trying another piece of software, I’ve found DietPi to be foolproof.

Just make sure you install all the necessary software you need for Roon, i.e. Roon Bridge, by usng the DietPi config.

Also, set up the correct DAC in DietPi.

Should be cake for someone who is familiar with RPi.

1 Like

Yeah, I’ve used dietpi before as a squeezeplayer for my LMS. I’ll give it a try again for Roon.


Ropieee does not install instantly. The image is a basic startup it then needs to download and install all its packages so it needs internet access from the off it can take about 20mins dependant on your internet. It also reboots itself a few times during setup. When the blinking stops to a slow steady rate it’s done. It does mention this on the site. I use Ropieee on 4 pi’s it’s by far the best for Roon and never had any issues installing you need to be patient. Then you need to configure it through its webui.

I’ve waited as long now, as 30 minutes. The ethernet port never turned on (the lights were off). How can it be updating if it never enables the ethernet port?
I even tried a different ethernet cable.

This RoPieee installation has me completely baffled.

1 Like

Are you sure the pi’s network card is actually ok? Considering you got no joy with previous os and now Ropieee something sounds not all right with the pi or your network somewhere.

I’m at an absolute loss here. This makes no sense.

  • I have have downloaded 3 RoPieee images (standard, standard compressed, XL compressed).
  • Using Etcher I’ve imaged a couple of Sandisk 32Gb Ultra micros SD’s.
  • I also imaged a no-name 8GB micro SD.
  • I have used both a Win 10 and Win 7 computer to do the imaging. Imaging goes fine.
  • I have used these SD’s on 2 different RPi 3B+ cards.
  • I have left the RPi boot and run for up to 30 minutes.
  • I have tried different power supplies (2.5A & 5A).
  • I have tried different ethernet cables and even a different switch.

In all of the situations above I get the same results: The green led flashes 7 times, pauses, 7 flashes, pauses, 7 flashes - etc, In addition the ethernet port connection leds never turn on - so the installation is not running.

Let me ask this: Before I run Etcher I delete all of the partitions on the micro SD. This is how I have always done it before when imaging for the RPi using diskimager. This is how you do it for Etcher also - right?
I found a list of LED error codes for the RPi and it states that 7 flashes means no kernel.img found. This hints that the card is maybe not getting imaged correctly. Is there something besides etcher that I can use? DiskImager that I normally use doesn’t recognize BIN files

DiskImage can do BIN files after all (just had to clear the default IMG extension). So, I imaged a card using DiskImager. But, of course - still the same led flash. No luck with this either.

To me, it looks like the images I’m downloading from RoPieee are borked.

I find it difficult to believe that all the RoPieee images are corrupt. I assume you are following this guide: https://www.ropieee.org/getting_started/ . I used Etcher to create the installer SD card, having first formatted the SD card with SD Card Formatter v5. I feel that the fact you have no Ethernet port light activity, assuming that you have a good build SD card created, signals to me to check the Ethernet connection, or possibly a hardware issue with the RPi.

This topic should ideally be moved to the RoPieee topic stream, where the creator Harry (@spockfish) will quickly step in to help.

Doesn’t this mean that the kernel can’t be found? So this either means a corrupt image or perhaps there is a boot partition to remove?

Edit: I also usually use the SD Formatter app to erase any SD card before I use Etcher, as @Edmund_Comber, with success. Could you try that?

I’ve never had to use SD Card Formatter before. But what the heck, I installed it from SDCard,org and formatted the card first and then imaged from Etcher. Same result of course - error flash for no kernel.img found.

If I use Disk Manager I see 2 partitions on the SD card. A small boot partition and a larger partition for the system. I always remove both before imaging.
When I run SD Card Formatter V5 there is only options to format a card, nothing stating “erase”.

I just had SD Card Formatter do a full format (took 20 minutes for a 32GB card). I imaged it with Etcher and this is what I see for partitions.

I still get the “no kernel.img error” after the full format and re-image.

Yeah, I think it should be moved. Is there a moderator for this, or should I start a new thread over there?

Maybe the Ropieee author, @spockfish, can weigh in on this problem. Thoughts Harry?

@Thomas_Prossima1, another suggestion to try:

  1. Remove all partitions using Windows.
  2. Then format using SD Formatter (quick should be fine).
  3. After you create the image, verify that you can view the kernel file.

I am somewhat at a loss as to what is going on.

This is a somewhat macOS-centric instructional tutorial that I created a few weeks ago. May be helpful though. https://youtu.be/NmVWMiPBjEw

After writing the image with Etcher, does it verify the image OK?

As you are familiar with the Pi, does it load NOOBS Pi OS (if it still called that) or Raspian? You will be able to see that on the network if so and verify that the Pi is not broken (may have a bad SD card interface)?

If you plug a monitor in to the HDMI port on the Pi you should see what’s happening at least until Ropieee is up and running then HDMI disabled

Im guessing you have a dud RPi - I have a dozen or so RPi’s with ROpieee and never any issues. I used to use Dietpi moons ago but Ropieee is so much more flexible, especially with XL now supporting Airplay, DLNA and Spotify streaming.

Moving this to #audio-products:ropieee area