Raspberry Pi + Pi-DAC+ volume control problems [Fixed pending next release]

Using a RPi 2 or 3 with Pi-DAC+

Configured as per documentation: http://www.iqaudio.com/downloads/IQaudIO.pdf

Roon audio setup volume configured as “use device controls”. Across the volume range volume is 100% regardless of state of volume slider. At 100% on the slide there is some volume boost.

When audio setup volume configured as “DSP volume” all works fine (but of course no longer lossless).

Attached some screenshots that should help diagnose. Anyone have any ideas? I have both a RPi 2 and RPi 3 that exhibit this problem

RAATServer log of me setting device to “device volume”, playing a track and changing volume in Roon Remote Windows: http://pasted.co/678ea1d0

RoonBridge is using the first volume + mute controls it can find on the device. That covers a lot of cases, but apparently not this one. I think the correct control is, paradoxically, the one called “Digital”. Not sure if it’s actually a digital adjustment or not–it looks like the driver or ALSA is making a bit of a mess, so something might just be confused about the names.

It would be good to understand more about why this device is laid out like this in the ALSA mixer, and if it is totally necessary for it to be that way. There’s nothing technically impossible about having Roon grab an alternate slider instead of the first one (which is the main one 99% of the time), but I’m not sure how that would look like on the settings screen.

It should be noted that the official IQaudIO images handle this tricky situation properly with zero configuration. If I had this device, I would strongly consider using it instead of RoonBridge.

Thanks @brian - got a little impatient - here in NZ download speeds from IQaudio are sloooow. :slight_smile:

BTW, the next build of RoonBridge should use the right volume control on pcm512x devices (IQaudIO, HifiBerry DACs).


@brian Sorry for reviving this old thread, but I’ve got another device with basically the same problem (don’t know the dac model).

As a possible solution, in the settings file RAATServer/Settings/device_xxx.json, you can already set the mixer/volume device. Since there are so few situations where it could be useful, couldn’t you make an option to set the ‘mixer element name’ (e.g. “mixer_element”: “Digital”) somewhere in there?

Kind regards, Maarten

@brian, This is fixed, right?

We haven’t done anything with this recently–based on my update above it looks like we fixed something last may. That would have been in production builds for a long time by now.