Reboot and select the proper boot device at startup

I have a NUC5i5MYHE with ssd M.2 sata (Transcend MTS800 64gb), 8 gb ram (2 x Kingston KVR16LS11/4 4gb)
I performed the installation following all the points of the guide:
BIOS update (last version 0047) I set the bios as described:
Use Legacy, not UEFI
Set the boot order from your SSD first
Disable Network Boot
Enable USB Boot but make sure the SSD has boot priority
You may need to enable the M.2 slot, depending on the BIOS version
Save your BIOS changes
(the ssd Transcend MTS800 M.2 is recognized in the bios)
I performed the roon rock installation without any problem.
But at power up, always keep sending the message “reboot and select the proper boot device
or insert boot media in select boot device”
Just restart by holding down F10 key and then ENTER (there is only the ssd Transcend MTS800 in the list of boot devices)
Then roon rock start without problems and works really well.
I would like it to start without pressing F10 key.
Please help! Thanks

I use exactly that device and mine works OK. I would check your bios settings again and look at boot sequence from within the bios.

1 Like

Thanks for the reply. this is the boot sequence in the bios.

I do not know what to do

That second screenshot shows that you have checked “Boot USB Devices First”. Just guessing here, but does this mean that the NUC will first try to boot from USB devices before the M.2 SSD, even though in the Legacy Boot Priority you have the USB device at a lower priority?

Yes, but normally I do not have any USB stick connected.
I connected it to capture images :grinning:
I have removed the check “Boot USB Devices First” but the problem persists
some ideas, thanks

I have a NUC7i5BNK. with ZTC SSD M.2 NGFF and 8 gb ram 1 Crucial DDR4-2400)
I performed the installation following all the points of the guide:
to the point where I ran the BIOS update successfully, but when it reboots I get this:

Intel Boot Agent CL runs no boot filename received. PXE-M0F: Exiting Intel Boot Agent. Reboot and select proper boot device or insert boot media in selected boot drive. I reboot and press F2 but it won’t let me configure my BIOS for ROCK.

Any suggestions of where i went wrong?


@Chip_Perry I’m sorry i can not help you. have you tried in some forum that talk about this problem on intel NUC? I looked for my problem but I did not find anything.

After many tests of installation of various operating systems, it seems that all those who start with legacy boot have the problem “Reboot and select proper boot device or insert boot media in selected boot drive”
and just start with F10 key pressed select the boot disk and all start without problems.
Only windows 10 with UEFI boot selected start without problems.
at this point it seems that it is the legacy boot mode that has this problem.
has anyone had this problem?
thank you and regards.