Remote Access from Outside Network

Please forgive me in advance for adding yet more one more topic to this discussion of mobile / remote access to Roon.

As I am growing more and more frustrated with the litany of solutions I must employ to enjoy my music in the way that I want to enjoy my music outside my home (Plex, Jriver, Tidal, Qobuz) all to do what ROON does at home) I decided today to have a go at connecting to my ROON ROCK NUC at home from outside the network at my shop. I’ve never really tried before and just wanted to see what would happen.

I installed a ROON Remote on my Mac Pro and as expected when it tried to scan for the core it could not find one. I clicked the “help” text and saw a screen for manually adding an IP address. I have a static IP address at home and have added port forwarding in the past for the ROCK as I had connection issues with the core over wifi from mobile devices in the past. As soon as I added the IP address for my home the Roon Remote on my Mac Pro found the Roon core and displayed everything beautifully. It was a bit of a “WOW” moment for me as I did not expect that to happen.

I went to try the same thing with my iPhone. At first, it detected Roon on the Mac Pro as they are of course on the same network at my shop. So I quit Roon on the Mac Pro and was then able to also manually specify the static IP address of the Roon Core at home. That connected instantly as well. Huzzah!

However, when I go to select an Audio Zone to play to, I can only see the devices on my home network. Hmmm. The dog will be thrilled.

Now I need suggestions. How do I add / create an Audio Zone at my shop that connects to the ROON ROCK NUC at home?

I have not tried this, just brainstorming here…
What if you set your shop network up the same way, with a static IP and port forwarding on the Mac Pro. Then connect a DAC system or endpoint by USB and then you may be able to set up an audio zone, and the two communicate back and forth by the static IPs and port forwarding?

Hi @Techru. Thank for the idea. I did as you suggested but Roon Remote with Core at home does not see Roon Remote at work. So Mac Pro at work is not an Audio Zone - yet! I’ll leave the port forwarding on though as I think it could be useful.

In “Roon Remote” -> “Setup” on home machine there is a place to add an ip address for a HQ Player. Might it be possible to add the ip address for a HQ Player running at my shop (if I were to get one)?

Roon does not officially support remote access. It requires all devices to be in the same sub-net.

1 Like

Hello,

This is how I got it to work. I listen to my Roon at the office. My roon server is at home.

  1. Used a Netgear Orbi, it supports OpenVPN. I am guessing any router which supports OpenVPN will work. I use that for my home connection.
  2. Setup OpenVPN on Netgear Orbi, download Windows 10 ovpn files. Copy those files to laptop.
  3. Setup OpenVPN on laptop, obtained it here https://openvpn.net/community-downloads/
  4. Copied the config files obtained from Netgear Orbi, copied them to the profile folder.
  5. Imported the opvn file into OpenVPN, then connected. At this point disconnect, then renamed the network adapter to NETGEAR-VPN
  6. Open the network adapter NETGEAR-VPN and set the address to static, same range as my internal home network. 192.168.1.x
  7. Conected to VPN using OpenVPN,
  8. Roon now thinks it is on the same home network, I opened it, set my audio output to my laptop and started playing music.

I have access to Internet, my home network, and Roon. I am happy with this solution at the moment. To get it working on my phone, I am going to install the software called connectify which will make my remote laptop a router, then sync my phone to it to share the VPN connection on the same subnet. I use a spare. Not a beautiful way to do this, but it works, would be nice if this was built into the app itself.

1 Like

Hi @Benjamin_Rose,

Glad to hear you have it working. Well done!

My configuration sounds a bit different than yours.

  1. My Roon Core is a Roon ROCK NUC.
  2. Modem/Router - Netgear v7610 (Telstra branded modem/router in Australia). It doesn’t have OpenVPN capabilities. I have been keen on Orbi though and this tips the scales even furthur to getting one.
  3. In house I connect to the Roon ROCK Core via Orchard Audio Pecan Pi streamer, Mac, iPhone, iPad, no windows machines.
  4. At work I have a MacBook Pro and an iPhone that I would like to remotely connect to my home network.

I may look equivalents to your configuration but I just want to ask…

You mention a laptop in your process. Does that laptop stay at home running 24/7 or is that what you use outside the network, from the office, to connect remotely?

Does the Roon Core and the VPN have to be on the SAME machine/device? I’m thinking maybe “No” because you setup OpenVPN on the modem/router? Edit I just watched a video on setting up OpenVPN on an Orbi and OpenVPN on a mobile client machine, so it looks like, no, the Roon Core and the VPN only need be on the same network, not the same machine.

Are you happy with the performance over the VPN? Is it glitch at all?

Cheers.

Hello Daemon,

VPN and core do not have to be on the same machine, just same home network.

Home configuration:

  1. A Windows 10 Desktop running ROON core (this machines run 24/7)
  2. A Netgear Orbi router, this is my home router
  3. OpenVPN feature, turned on on router.

Work configuration:

  1. A laptop running windows 10, with OpenVPN software installed. Netgear Orbi generates the profile files for OpenVPN, copy them to laptop.
  2. Laptop runs the Roon client.
  3. The important step is to give the laptop a static IP (same as home network) on the OpenVPN network connection.

I am happy with the performance at work. I have a good upload speed of 40MB up at home.

2 Likes

I run a pfSense firewall which has OpenVPN server embedded but unfortunately the clients that connect to the network from outside, will get an IP of a different sub net thus it will not work.
How did you manage to get addresses from the same subnet for your clients?

I had the same issue at first. I went into “Change Adapter Settings” in Windows 10 and manually set a static IP address for the VPN adapter. I set it for my home settings. I was surprised it worked, but it worked. Have access to Internet and access to my roon server.

1 Like

I will have to try that as soon as possible despite my main laptop is running Linux. I have another laptop running windows though so I will have to investigate.

So to understand, you modified under network settings the VPN adapter and gave it a random 192.168.1.X address. Then you connected to your home network from a remote location and you were able to find Roon Core?

Thanks for all your help!

thx @Benjamin_Rios