Remote cannot find/choose Core on QNAP [Resolved: RoonServer needed an update 1.2 to 1.3]


I am a complete Roon newbee. I installed the software on a Roon recommended QNAP meeting all Roon requirements as such (Roon on a Samsung SSD 850 PRO 128GB, music collection on two WDC WD10EFRX). How can I check whether Roon is actually running and/or installed properly. I see no user interface.

It is connected in our network (cabled). Router is a FritzBox 7360. Other network equipment: a 3-COM 2824 Baseline switch. I do see the QNAP on the Windows machines in our network. I have also installed Roon (as Controller) on a Windows machine in our network. Nothing to be found. I have no good knowledge of the more advanced configuration of a NAS (port configuration networkservices on/of?) So if you have any suggestions in that respect please be “gentle”.

Best regards & thank you!


Is the Windows Machine on the same network subnet as the QNAP?
If you’re not sure post there IP addresses on here.

Is the windows machine connected via WiFi or hardwire Ethernet?

Just as a test try disabling the firewall on the Windows machine.

Hi Carl!

Thank you very much for your prompt reply!

Yes everything is connected to one and the the same (sub-) network. We only have one. Apart from our iPhones iPads and Samsung tablet, all the equipment has cabled connections to the network. I have followed your suggestion to diasble the firewall on the Windows machine that I tried to us as “Control”, but to no avail.

I may have made mistakes in the configuration of Roon on the NAS (QNAP TS-453), but I don’t know how to check this, as I cannot find a Roon user interface on the NAS. (Perhaps there isn’t any?)

Thank you again!

I assume that you’ve followed Chris Rieke’s guide and installed his software? The reason that you can’t find a Roon user interface on the NAS is because you have installed Roon Server, and it doesn’t have a user interface - as pointed out in the guide.

I don’t have a NAS in my setup, so can’t help you further, I’m sorry. Perhaps the best thing would be to page Chris (@crieke ) and move this question into the QNAP/Synology forum - I’ll do that.

If you started with fresh, there should no RoonServer and RAATServer folders on your RoonServer share. After RoonServer has been launched for the first time, they will be created automatically. So, if you check your RoonServer share and these folders are there, it is a good indicator that RoonServer has been launched once.

You can also force the RoonServer on the QNAP, to write a log to a text-file:
Create an empty plain-text file on your RoonServer share ROON_DEBUG_EXTERNAL_LOG.txt. Then stop and start RoonServer again on in the QNAP Appcenter. When starting RoonServer again, it will see this file and use it as a log.
Take a look at the content afterwards.

Your RoonServer share should look like this, then:

Hello Christopher,

Thank you very much for thinking along. On my Windows machine I see exactly those folders, except for the .txt folder which have not yet created. In the RoonServer file I found very large log files.

Thanks again! Harm

Yes, that is RoonServer’s own log. So, I’d assume RoonServer is running.
If RoonServer still can’t be seen by Roon on your laptop, I’d also suggest to check firewall and network of your devices settings. If you have a smartphone at hand, try to install the Roon app there and see if the issue persists with that device as well.

Chris, I have installed the Roon app on my iPhone, our iPad, and the one Windows machine I mentioned. All these devices indicate that they start searching for libraries, but none of them succeed. All devices are in the same network.

Thanks again.

Could you try the above step to create the ROON_DEBUG_EXTERNAL_LOG.txt file, then Stop and Start RoonServer again and paste the output of that log here?

If there are any errors when starting RoonServer it should be written in that log.

On Windows it is sometimes a bit tricky, as it hides the extensions by default.
It should work if you open your RoonServer share in the explorer. Right click in that window an select “New” -> “Text file”.
Then enter the file name without extension: ROON_DEBUG_EXTERNAL_LOG

Only have a German copy of Windows here:

Hi Christopher, Idid as you asked, but the .txt file remains empty. I tried to copy and paste the most recent log file from the RoonServer directory on the QNAP but that appeared to be too big to copy here… Is there a specific part in that file you would be interested in?

Thank you Geoff!

I have sent you a private Mail. (The green dot on the upper right side of the community forum)

I received your log by email. Can you tell me where exactly you copied it from?
It is created by RoonServer 1.2 (build 161).
I guess it is the log from your computer (not from the RoonServer share)?

Did you create a new shared folder on the QNAP?
Maybe you can make a screenshot of the QNAP system log:

  • Enter the web administration in the browser, by entering the IP of the QNAP in the address bar.
  • Login with your QNAP username and password.

When logged in there is a small icon in the upper right side for notification. Click on it and click on “More”:

A new window will open (the System Logs window). Search on the upper right side for “RoonServer”.
Then click on “Save”

Can you send me the downloaded file?

Hi Christopher,

To my knowledge I copied the file from the RoonServer share. Maybe you should know that I started with this NAS in November last year. Perhaps that’s why the log stems from RoonServer 12 build 161?

Yes I did create new shared folder which I named RoonServer.

I wille send the saved file to your private mail address.

I have an idea what might be the case:
Can you try to uninstall the RoonServer application in the QNAP AppCenter and download the current qpkg from my blog and install it again? This process won’t touch your RoonServer shared folder.
But it will download the current version of RoonServer (1.3).

Okay Chris, I will do that and I will keep you posted. It may take a few days before I come back on this subject as there are a few other things that (also) need my attention…

Christopher! You cunning man! It works. I should have known… Always check whether you are running the latest software. I feel a little ashamed, but I wouldn’t have thought an older version of RoonServer wouldn’t run at all. Sorry about that. Thank you very very much. I hope I haven’t wasted too much of your precious time.

Best regards,


Great, that your Roon is running again.

RoonServer 1.2 and Roon 1.3 clients are not compatible. But I think there is normally an info screen, that should have allowed you to upgrade the Server. I have no idea why it was not shown in your case.
(I am not sure about smartphone devices, but your windows machine should have…)