Remove Tidal from Roon?

I used to have a Tidal subscription but no longer use it as I’ve switched to Qobuz, I keep getting a login failed notice with the only option to log in or sign up. How can I stop this happening?

Settings==>Services==>Edit (for Tidal)


After I click on edit the only options I have are to sign up or log in

Deleted image, all sorted

Hmm, try logging in with your old info (it should let you do this) and then disable.

1 Like

That worked a treat, many thanks!

1 Like

@support looks like a bug to me.


Hi @HabUK,

I’ve enabled diagnostics on your account so we can take a look at what happened here.

How long was this error occurring? Did it just start after an update?

Can you describe your Core and networking setup?

A post was split to a new topic: Removing TIDAL account from Roon

2 posts were split to a new topic: Can’t disable TIDAL

A post was split to a new topic: TIDAL Login failed - Don’t have TIDAL anymore

A post was split to a new topic: Removing TIDAL from Roon

I can confirm this bug is still occurring. My trial of tidal expired today and EVERY time I open roon on iphone it tells me to log into tidal. I got to services and there’s a spinning wheel next to the tidal login. Please fix

This has worked for others -

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.