Removing Genre from multiple albums

I have several 100 albums where I need to remove one of the genre tags.
I’ve tried selecting a group in the FOCUS screen and editing, and everything LOOKS fine. But it doesn’t work.
Does this feature work?

Did you select multiple albums before entering the Album editor? I’ve just tried it on my own library, and it seems to be working as designed (although I just removed a genre from a test of just 5 albums).

I just used the feature a day or two ago, so yes it should work.

Note that you first may use a Focus to only display the albums you want, but as a second step you still have to make an explicit selection of the albums. (The Focus itself is not yet a selection). This selection could be „all“ that are visible in the Focus, but it could also just be a subset.

Once you have a selection, click the (…) button > Edit.

You can multiselect as described here:


Just tried again with three albums. Selected the three, then edited to remove the “Jazz” genre. But when I look at them again, “Jazz” is still there. I can do one at a time (so presumably not a permission issue).

Hopefully the pic shows what I did.


I notice that you appear to be doing the edit on a smartphone. Did you scroll down to the bottom of this screen and touch Save?

If you did, then can you try this on a PC, Mac or Tablet? This may be an issue with the limitation of functions on a smartphone…

It is working for me…