ROCK Boot Error

Hi, I’ve been getting the following error when booting up my ROCK:

I’m running it on a USB 256gb SSD plugged into an old Lenovo laptop (i5, 16gb ram). I had managed to successfully run ROCK on this machine for a couple of weeks following this same boot error (just took a restart), but I ran into issues while importing some music files and had to restart - only to receive this error once again. I’ve tried restarting the computer several times, reflashed and reinstalled ROCK, but I’m still getting this error upon boot.

Anyone else ran into this error? Any BIOS settings to rec?


I have no idea how this unit was installed. It’s a super unsupported/untraditional setup. What happens if you boot without the USB disk?

To understand what is failing first requires an understanding of how Linux boots and this is a decent enough read on that:

The errors you’re seeing are happening between step 2 and 3. The Boot loader and kernel control device drivers (before modules can be loaded) and that means the boot loader can support something the kernel does not. This includes drivers for storage. You don’t show the entire boot messages but I suspect the kernel (ROCK) doesn’t support the drive or filesystem of the root partition. But that’s just guess with not enough information.

This thread should be moved to tinkering.

If this is a driver level problem with the ROCK kernel you won’t be able to fix that. You’re safer installing some flavor of Linux and booting Roon Server. That will let you maintain a bootable system independent of the Roon Labs software.

1 Like

I know it’s a weird setup, but I wanted to strip back my system and see if I could run Roon on something without windows. Without the USB there is no OS, but it will boot to BIOS just fine.

Thanks for the link. It definitely seems to be an issue of hardware mismatch preventing the boot. It’s very weird that I managed to get it to work the first time, but not now. I’m going to try formatting the drives, see if that makes a difference.

If that doesn’t work I’ll probably have to stick to a windows install.

Linux. Try getting something like Ubuntu functional. If you get comfortable installing Ubuntu then you can move onto lighter distributions. But running Linux on that machine will give better performance over Windows.