ROCK can´t find a Devialet Premier over WIFI

(JOSE OLIVEIRA) #1

Hello,
I have a network with a main wifi router for all the house and one specific to use with a Devialet Premier, positioned very close to it, that setup was working fine when I used the Roon Core running in a Windows 10 computer connected to the main router. The D-Premier WIFI could be found over the network with no problem.
Now I installed a ROCK that seems to be running ok, all libraries were properly imported, etc…
It can be acessed remotely from my ipad or android phone, looks nice.
BUT, now the ROCK can´t find the Devialet Premier as an audio output on the network.
To test if the Devialet was connected, I also installed the Devialet AIR on another computer on the SAME ethernet cable/connection of the ROCK, to my surprise it found the D-Premier connected to that exclusive wifi router.
Please, is there a way to manually set the ip address of the audio device on the ROCK core ???

(Mike) #2

You can set a manual address from the ROCK web interface by clicking the “static” button and entering it. Though I prefer to use DHCP, as auto-discovery works fine in my experience. You should be able to find your Devialet in audio setup if its connected to the same network, or via USB.

(JOSE OLIVEIRA) #3

Thanks, but I can find the ROCK network address automaticaly, the problem is that ROCK can´t find the Devialet address… There is no way to type the Devialet IP address into the ROCK settings?

(JOSE OLIVEIRA) #4

Hello, I managed to make ROCK find my D-Premier over the network, it was a bridge connection that need to be properly reset on the router.
BUT…
Now, when I try to send the streaming to the Devialet, I keep getting an error msg. “AUDIO DEVICE I USE”… :pleading_face:

#5

Do you still have the Devialet AIR driver active on ‘the other’ machine? If so, uninstall it and then cold boot (remove the power cord, wait a minute or two) your D-Premier. That ought to clear up the error. Two instances of AIR connecting to the amp will produce this…

1 Like
(JOSE OLIVEIRA) #6

Thanks! I removed the AIR driver from all computers over the network, the problem persists, ocasionally the error disapears, but then it returns!!! :unamused:
This kind of random behavior is the worst scenario to find a solution…
I decided to buy a full Ubiquiti network setup, hope this solves all problems!

#7

I remember these errors from the time when my amp was a D-Premier. I had many files with 96kHz and above so I moved to USB. Air streaming at that time was not stable. Which firmware are you using on the amp?

1 Like
(JOSE OLIVEIRA) #8

Using the latest firmware, I remember that about 5 years ago the wifi streaming was really bad, but everything got MUCH better once Roon natively supported the Devialet AIR protocol, stopped all problems like that. It only came back, randomly, when I began to use ROCK on a NUC i5 6th generation.

#9

So ROCK is somehow involved here… what was your Roon core before ROCK? Can you temporarily try that again to see if the problem goes away?

1 Like
(JOSE OLIVEIRA) #10

I used the same 6th Gen i5 NUC running Windows 10 with Roon, now I removed the M.2 SSD from this NUC to an ITX PC and really don´t want to put it back, since the M.2 slot is hard to reach on this PC. Already tried it running Roon and that still works ok.
But, the ROCK speed for all tasks like managing/importing the audio library is much faster than the W10 runnig Roon core, so I guess it must be a great way to stream to Devialet, once properly configured.
There should be a way to override the “device in use” error, I guess it must be some kind of protection against someone interrupting the Devialet while it´s already playing, just that. If the owner doesn´t mind about this risk of interruption, the system should allow to be bypassed by the next task.

#11

Even on the same hardware you get the difference between W10 and ROCK. Any Roon updates in the meantime? Have you still got Roon on the ITX PC?

(JOSE OLIVEIRA) #12

Yes. The Roon is still installed on the ITX so I can control the ROCK from there sometimes, instead of my iPad Roon app. I always keep the latest version of Roon installed everywhere. There is one last try that might work, I don´t know, plan to try it this week. It would be to connect the ROCK NUC directly to an small wifi router making an unique network, just with the D-Premier linked by wifi and the NUC by ethernet to this router. First trial will be without even the NAS, only with the NUC internal 2TB HD and some music files. Hope that works!

(JOSE OLIVEIRA) #13

Good News!!!
Problem solved! Ubiquiti is a winner!!!
Once I changed just the access point for an UAP-AC-PRO placed near the D-Premier, everything is working fine, no more errors and the audio quality improved A LOT !!!
It was all a fault from the previous network gear (Asus and Microtik) that became to randomly affect the connection quality.
Also, the ROCK NUC connected directly to the secondary ethernet port of the access point works perfectly, I will leave it there.
Thanks for all the help!!!
Regards,
Jose

1 Like