Rock Dual Ethernet on NUC, subnet not working [Solved - SOTM: known issue with Mac OS/ Safari interface]

From this thread ROCK Dual Ethernet - Primary Port Not Exposed [RESOLVED]

I understand that it is possible to have a subnet configured on my NUC communicating directly with my endpoint SOTM SMS-200. however it does not work for me, i have a intel NUC7i7BNH connected with an USB-C ethernet adapter as the second port. I can use both ethernet ports configuring them thru DHCP or static, roon Rock functions fine. Then foolowing the instruction I configured one port with a static adres ,, rest empty and do a bit the same on my Sotm SMS-200 with address after the settings are accepted and optional reboots the roon endpoint disapears from the roon clients. I can still see and operate my microrendu also on my other subnet Rock is at

The named Instruction looks very straightforeward, but i did several atempts switch ports , used diffrent ethernet adapters, reboots etc all with the same result, endpoint cannot be seen by Rock after changing the endpoint to the subnet.

I have Rock and Sms-200 latest version running, any ideas what i may have missed here?

Try it as

Unfortunately , is what i already used, Typo… Anyway , i cannot manage to get this to work , i have Rock successfully running on my Intel NUC, ik can apply both the ethernet ports on it, when i configure one port with the subnet , I can ping the port from a Roon client PC configured as, and can also connect via the ROCK OS web client, so that part seems to work.

Following the instruction, I configure the SMS-200 from DHCP IP to Static IP , Disconnect it from the switch and connect to the second ethernet port on the NUC and reboot.

after SMS-200 is rebooted, the SMS-200 disappears from all Roon clients, MSG “Please select Audio device” when i pop open the zone selection only the Microrendu is available for selection (other endpoint) . after that i cannot access the SMS-200 anymore thru the EunHasu web client ( which is correct) . Luckily the SMS-200 defaults back to the old subnet , when disconnected > 15 min. After i get my network IP back on the SMS-200 and reconnect it back to the switch port. the SMS-200 pops back in the Roon client(s)

Tried this several times in different order, all with the same results.

BTW, i had this working when i still used my Mac Mini as Roon server. configured as bridge, I connected the SMS-200 directly to the second ethernet port of the Mac, working flawless and as result better SQ to my ears.

I also attempted for ROCK to have everything on the same subnet 192.168.178.x as i did with the Mac mini, but with the same results as named specified subnet, no joy.

Did you also, leave the gateway and dns blank for both the ROCK NUC and SMS-200?

If you can ping you Roon from client from, that means you are in 5.1.1.x network.

I suggest you use the default 192.168.178.x network. That means, use the following set-up:

NUC (Intel) ethernet 1 port:

NUC (USB Ethernet adapter) ethernet 2 port:
gateway: (◄ or change it to your router IP)
dns: (◄ or use your preferred DNS service)

sMS-200 IP:

The 5.1.1.x IP should not be used for this purpose. Even if it is used behind a firewall/NAT. It is a public routable IP.

Private ranges are - (65,536 IP addresses) - (1,048,576 IP addresses) - (16,777,216 IP addresses)

if the NUC USB Ethernet adapter has
the direct link between NUC and the sMS-200 can use 192.168.177.x with .1 and .2 and a netmask of You can of course use and on the direct link too

1 Like

Thank you all for your good advise. It is clear to me how this should work, however it is still not working for me. I now noticed what seems to go specificaly wrong here;

When i change the SMS-200 to a Static IP, entering all the values by pressing the like this;

dns: (or empty)

The related fields become green and confirm valid. Then I click Save & Reboot, what happens is that the previous DHCP generated IP seems to stick in the SMS-200 (now . Normaly I plug the SMS-200 cable in the first ethernet port of the NUC after the change , always without result. Now by leaving the SMS-200 connected to the switch after reboot it directly connects thru and as result i can also open Eunhasu , go back to IP config screen and see the IP still there “Static” etc. On the bottom of this setting screen is an summary of actual operating parameters , there DHCP and IP IP shown??

In summary; using latest SMS-200 firmware ver 0.4
It seems the Static IP setting is for some unknown reason not adopted by the SMS-200.

I also noticed from the IP settings screen that in the four fields; IP, Netmask, Gateway and DNS. a dynamic circle is spinning constantly, like it is searching data or timing out. even after entering the correct values it never stops.

Further the SMS-200 seems to operate as expected.

Any clue what is happening here?

Right. Your SMS-200 needs a DHCP server. As it does not find one (on reboot) it uses the IP it had the last time it talked to DHCP. As your NUC is running Rock - which does not have a DHCP server I’m afraid you are out of luck… that is until the SMS-200 can be configured with a static IP.

You are right that the sms-200 needs a static IP, and that should be possible from ver 0.3.9 , i,am on 0.4.0. So from the config screen of sms-200 i can toggle between DHCP and STATiC en congure a manual IP , but as explained it shows some eratic Behaviour, i can configure it but it does not stick.

If understood correctly TOPQuark has this working with an sms-200 ?

It seems so, yes. You may need to ask SOtM how to do it. If the SMS-200 can remember it’s static IP this should work. Remember that the web interface (eunhasu?) will not work unless you configure an IP in 192.168.177.x on your PC and connect directly to the SMS-200.

I agree with @ogs, the next step would be to verify with Sotm on how to setup the static IP. It does not sound like your changes are “sticking”.

I just want to let you know that everything is working to my satisfaction now, the SMS-200 is directly connected to my NUC, ethernet port 1.

However , to reach this status was quite a journey, let me summarize;

At certain stage I discovered that all my IP entry attempts in the SMS-200 where NOT stored after “Save&Reboot” This was confirmed when I left the SMS-200 connected to my switch, directly after reboot it would directly reconnect to the previous (DHCP) IP setting. I contacted SOTM and they advised promtly to Reburn/ clean install the SMS-200 with ver 4.0 image as i did (several times), with exact the same results as before.

As already noticed in my previous mail i mentioned the constant spinning circles at the IP entry fields within eunhasu as odd and suspected that my eunhasu web interface running under latest Safari (OSX) was not actualy transferring my settings to the SMS-200. As result, I installed an alternative browser (Google Chrome) and redid my previous attempts, and now with a different result, the entries were actual sticking…(spinnig circles also stopt after pressing )

I got confirmed today by SOTM that there is a known issue with Mac OS/ Safari interface ein this matter and that they will fix it in next release.

1 Like

Don’t you just hate these browser wars …