ROCK failing to install on J3455

Newcomer on the forum and have just discovered the splendid world of Roon.
I’m having a bit of trouble installing ROCK on a NUC 6CAYS with the J3455 chipset. I have followed all the instructions but when trying to flash ROCK I get a looping notification stating “waiting for USB subsystem to initialize”. It goes on forever. I know the 6CAYS isn’t officially supported, but do anyone have an idea of how to sort this issue out? All answers are highly appreciated.

What is the spec of your machine? SSD, memory etc.

It’s a Centrino 4 kernel @1.5gHz, 6th Gen NUC. 6GB of RAM and a built in 32 GB Kingston MMC SSD and a Samsung Evo 850 m.2 SSD in a m.2 to SATA bay. The RAM is one 2 GB Ataki or something stick and one 4 GB Crucial stick. Nothing fancy but works as a media PC and Roon Server.

The main think with ROCK is it doesn’t like UEFI mode, you need to be in legacy boot mode. So assuming your usb drive is OK I’d look there.

Thanks for the replies. Legacy boot mode is enabled, UEFI disabled. Seems like the installation halts almost at the beginning. See image of the problem.

Tried a couple of different USB drives and a SD card with the same result.

I can’t see the image I uploaded, can anyone?
Here’s a link to the picture

Seems almost like ROCK is not compatible with the USB hardware in this NUC? Or maybe the hardware is responding with an unexpected message. I guess the only one that can really help here is @danny.

Thanks. Hopefully I’ll get a response.

@ogs, how can I help? It’s not a supported model.

I know it’s not supported, but some kind of explanation maybe…

Hi ragwo, not much to do other than set up your NUC with one of the Linux distros and install Roon Core. That should work.
I use a standard Debian because I’m used to Debian CLI, but there are probably better distros for this purpose. I never tried ROCK as I doubt my rather old NUC would work…

Have you tried all of the USB ports?

It seems there are internal USB 2.0 ports as well - if you can find a USB header for them try them as well.

Thank you for all the replies!
@wklie I haven’t tried all USB ports, just a couple. I’ll give all a go later this afternoon.
@ogs If nothing else works, I’ll try Linux. Thanks for the suggestion.

Due to the severest attack of man flu known to (man)kind, the project is postponed until I resurrect from half dead. Will keep you updated.

Getting closer!

The combination of a new USB stick and a different USB port was a success. ROCK won’t recognise the on board Kingston MMC SSD, think I’ll have to get hold of a m.2 SSD.

The back light bleed on my Samsung TV is horrendous by the way.

It’s not supported because I didn’t have one when building the operating system. I did not consider the hardware configuration, the firmware blobs and/or drivers needed to make it work.

I didn’t bother with this model of NUC because it is below our minimum recommended specs. It might work for some, but we wouldn’t recommend it to anyone.

Thanks Danny, that is reasonable. Let’s see if the OP can make it work. This NUC is quite similar in processing power to the QNAP/Synology boxes that handles basic Roon server duties. If ROCK can run on the NUC it might even be a little better… Would make a nice MOCK!

I’m officially ROCKing/MOCKing!
Thanks to all for the replies and suggestions. It isn’t the fastest UI experience, but I’ll live with it for now.

So what was the problem? Faulty USB port and faulty USB sticks?

Apparently. Everything is fine now. Thanks for your help!

The repeating messages probably meant the USB stick was not found. Although an incompatibility is certainly possible, my reasoning is that the USB hardware in this particular NUC should not be too different from the other supported NUC models using the same generation of Intel chipset.

That is more likely, yes.

Maybe time for me to try ROCK on my old-ish i5 NUC? I’ve just mounted it in a silent cabinet from Akasa. Just about time, the fan and cooling vents where heavily clogged with dust…