ROCK - iFi nano BL iDSD not recognized/detected

Core Machine (Operating system/System info/Roon build number)
ROCK / NUC8i3 configured as per your specification (disk and memory components exactly as per your codes) BIOS updated to the latest release.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
iFi Nano Black Label DAC updated to the latest firmware.

Description Of Issue
Good evening,

The iFi Nano Black Label DAC is not detected by ROCK but is regularly recognized on Windows computers (from which I write) as an endpoint …

What should I do?

I specifically bought everything to configure a system by using ROCK that I don’t want to deal with problems related to Windows … please help

Thanks in advance

paging @support

I have one and it’s always worked. Have you tried rebooting ROCK with it attached? Have you also tried having it on before plugging it in so it’s running of its battery and not from USB port? Which firmware you running on the Ifi?

Hi @Paolo_C,

Just to verify, this is connected directly to the NUC vis USB?

Can you share a screenshot of Settings > Audio?

Hi Dylan,
the dac is connected directly to one of the usb inputs on the NUC using the usb 3.0 cable supplied with the iFi nano BL idsd

I tried both the two rear usb ports and the front (yellow) port without any variation of result. I tried to

  • turn on the dac before connecting it to the NUC (power supply with battery inside the dac)
  • turn on the dac after connecting it to the NUC (power supply from the usb port)
    without change in the final result

about the screenshots of the audio setting… in practice I have no configuration possibility because the dac is not recognized/detected (the green LED on the dac flashes to indicate “waiting for connection”) and no configuration is activated, that’s all I see:


when it is connected to the windows computer it is recognized as an endpoint and various configuration options are available

@CrystalGipsy … the Nano has been updated to the very last firmware to be able to play MQA, perfectly detected by Roon on my windows7 computer using the same cable I use with NUC

Very odd mine has always worked fine. But I don’t use the latest firmware as it upscales everything to max pcm and I don’t like the upsampling filter it uses.

@CrystalGipsy … looking at this thread it doesn’t seems your unit worked always fine… anyway…

Yeah had issues with MQA playback only, which they have found the culprit and fixed in next release. This was not using the latest firmware. It always showed up in ROCK though and worked fine on the newest firmware I just don’t like the sq of the latest one. GTO filter sucks.

Hi dylan, something strange is happening… back home I found this situation


this is what happen if I connect the dac to the win7 computer with another usb cable (cheap and old)…


it is immediately there

… and this is inside ROCK

I tried stopping and restarting the Roon Server Software… nothing…

now I also tried OFF, unplug power cord, push the power button (with no power cord IN to be sure the NUC was completely OFF) then back ON the NUC … it finally detected the Nano to the NUC, changed the usb input “on the fly” and the nano seems is still there…

I don’t understand … why?

in the mean time I’ve seen that Roon on the pc does not refresh/update the available audio zones if the status change after it has been started… my raspberry was off-line and when I plugged it back to be seen by Roon I had to OFF/ON the Roon software

Hi @Paolo_C,

So after rebooting both the NUC you’re able to see the device okay? Is the device working properly now and remaining seen in Roon and you’re able to play to it okay?

hi @dylan ,

it seems now it is stable… I tried this morning powering OFF … pause (couple of minutes)… ON… and the zone is still there, I didn’t had the time to unplug the power cord (I don’t know if it makes sense or not) and I will try this evening but so far seems fine

thanks a lot for your kind attention to my help request, I will post here an update in case of further problems

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.