ROCK Install Feedback

I dont think roon 1.3 is any different in ROCK…it is only a minimalist os to run roon 1.3 server edition…don’t see what the problem would be…

I have read somewhere on this forum that it might be possible Roon would add some possibility to run applications in ROCK…Hqplayer would be a good start then… :slight_smile:

Just got my ROCK up on a NUC7i7BNH with 250GB Samsung 960 M.2 NVMe SSD and 8GB Ram.

Very happy with the upsampling to DSD512 at 2.0-2.1X processing speed, only dropping to 1.9-2.0X when using all 4 cores for audio analysis.

Haven’t been the room yet where its running while all this is going on - but will see if the FAN noise is as much of an issue as others say it is.

@wizardofoz: What dac do you have?

Yes it would interesting to know how much fan noise you get?

Oppo Sonica … connected via RPi running RoPieee

It’s actually quite noisy while it’s running 4 cores of audio analysis at the moment in a non air conditioned room…but I’m heading to bed now so not going to bother me…if I need to listen in the day I’ll turn off analysis or throttle it down

3 posts were split to a new topic: DB didnt transfer properly during transition to ROCK/NUC

Ok, so you say that NUC7i7BNH can handle DSD512 upsampling with ease? Did you try any DSP room correction filters plus DSD512 upsampling in one zone? If it can handle these, then I will be purchasing it

I only use the up sampling…but not really using much more than 256 for the most part these days. I mostly upsample on my fanless i7-7700 as its windows based and I need the ASIO drivers for the Sonica DAC to get to DSD512

Hoping someone can help me here - as I’m struggling to get this going. I’ve downloaded the rock gz file, used Etcher to create a flash drive and I simply get “a bootable device has not been detected” when starting up.

I have:

  1. Tried multiple USB pens
  2. Tried different bootable utilities (such as Rufus)
  3. Disabled Secure Boot
  4. Booted the NUC to a Win 10 USB - which works and it can see the M.2 drive (so it’s not the fixed disk that’s the problem).
  5. Updated the BIOS to the latest version from the Intel site

Any ideas?

Did you uncompress the .gz file first? You need the have a .IMG extension before you install it on a usb stick?


We have a winner. :slight_smile:

Ok, so not quite there yet I’m afraid.

I’ve extracted the .gz to an img and used Etcher - so far so good, but the NUC is still throwing the bootable device not found error.

If I plug the USB pen into my Windows 10 PC, I get two drives - one contains:

identity (folder)
roon.tar.bz2 (file)

The other drive is inacessible by Windows (and I get the usual “do you want to Format it?” question).

The first drive is 200Mb formatted with FAT and the second drive cannot be read at all (but appears in Explorer nonetheless),

Is this what you’d expect to see on the USB pen?

@Duncan_McDonald Have a read of this Computer Audiophile Rock install guide if you follow it EXACTLY without skipping any steps it works perfectly.

Thanks Ratbert - your pointer has revealed why its not working.

The Intel NUC I’ve bought is the NUC8i7HVK - “Skull Canyon” (8th Gen i7) - and about 3 BIOS revisions ago (mine came with 042 and they’ve recently released 049) in version 037 they removed support for Legacy Boot. The screenshot on that link you’ve given clearly shows Legacy boot options on the right hand side of the screen - mine has none of that.

So my next question is… is it going to be possible to install this if I can’t disable UEFI?

No. ROCK does not support UEFI – so your NUC needs Legacy Boot to run.

Kindly note that the NUC8 is not a supported model:

Hi guys. No problem with TIDAL playback on your NUCs with installed ROCK?

No problems here.

Nope all good here too

Everything OK now. Problem was my TIDAL account…

Installing ROCK on a NUC5i3RYH, installed the OS from the flashed USB stick and rebooted. Everything was looking good until I got an invalid IP address: http://169.254.XXX.XX. Rebooting gave same result and the ROCK is not visible on network and not found by Roon. Nothing in troubleshooting about how to solve this issue. Basically, at this point my NUC is a brick unless I can find a way to give it a valid IP address.

@Robert_Daines Your NUC is not getting an IP address from your network. Assuming you are connected to your router or a switch that has a known working port and more importantly you have tried another known good LAN cable.