ROCK Install unable to access USB connected data drive

Intel SWNUC12WSK1700 with USB WD Elements WX22081LRT8D
everything worked fine.
Now I cannot add the USB drive as the music storage folder in Roon.
I have tried two if the WD Elements drives connected to different ports on NUC - they fail to show up at all.
Right now I can only connect to a network share, but it seems Roon runs background processes frequently which creates noise that is not acceptable to my partner in the sitting room.
Any suggestions? Thank you!

How are the drives formatted?

Did you maybe rename the drive.

Roon uses some obscure name derived no doubt from the USB drive itself , if you rename it Roon will lose it

You should format the drive exFAT for preference , if you haven’t copied a lot to it maybe reformat it , pu it into the NUC and restart the NUC.

I don’t think I have removed mine since it was plugged in

Thanks for the help.
The WD drives are NTFS format.
Windows show the drive name as Roon.
Happy to reformat and recopy the library…but it was working fine!

ROCK is linux based and linux and NTFS don’t play well. If for any reason there was a unclean disconnection, like the NUC lost power, or, the usb drive was just pulled out, NTFS drive can get into a error state. Plug it into a Windows box and check the drive. It should fix it.

IF you reformat the external drive to exFAT, then there will be less of an issue in the future.