ROCK installation on a NUC10FNH with the latest intel UEFI

I’ve unboxed my NUC10FNH today. Bought for turning into a ROCK server.
I tried all the suggested BIOS settings from a load of forums.
Secure boot is disabled, performance standby is set to then the old way. USB device booting set to first.
It has the latest intel BIOS, as per ROCK installation instructions, which makes it effectively an UEFI only machine (according to the intel doco).
Hence the boot on the flash image fails on the (linux) MBR.
I’ve tried etcher and rufus. Same result.

How do I get ROCK installed on this UEFI cube?
tia

First, welcome!

Second… Oof. I have the 10FNH, but when I built mine the latest BIOS did not turn it into UEFI-only… it was still possible to disable secure boot. So the new BIOS makes that impossible? I knew that was true for the NUC11, which meant that you couldn’t install ROCK on a NUC11. Is that actually the case, or were you able to match the BIOS settings from those threads precisely? If that is so, can you roll back to an earlier BIOS which doesn’t have that requirement?

Thank you for your quick response.

  1. I was able to disable secure boot. This setting allows you to boot images which are not signed.
    https://uefi.org/sites/default/files/resources/UEFI_Spec_2_7.pdk
    But the legacy boot stayed greyed out.

  2. I did some further surfing and found the tip to set the performance/standby to legacy.
    This should then enable the legacy boot boot after a hard power down of the machine (remove the power cord)
    This does not enable the legacy mode. It stays grey. Hence the machine is UEFI mode only and requires a GPT flash image.

I also have the boot USB device first on. And this does not really matter if you go the the boot menu with F10. When I select the flash drive in the boot menu it returns to the Boot menu as the UEFI does not support MBR.

Intel has a list of NUC which support Legacy BIOS/BOOT support on

dated on 10/08/2021

The latest BIOS is on

dated 2021/12

Release notes

FYI: UEFI and booting Linux:

FWIW: I bought this NUC10FNH hardware as advised on the Roon site. I feel a bit reluctant to turn this NUC into a Windows machine when I can/could have it ROCK on the bare bone machine.

Please, please prove me wrong on the legacy boot.

From a different website, it mentions disabling both Secure Boot and Modern Standby; both of those must be disabled before you can enable Legacy Boot.

I don’t know if this works as I don’t have one to try it, but, it might help.

2 Likes

tried that. Legacy boot was not possible/accessible

I had this on my 10th Gen NUC as well. I did a post helping another user through the same problem, as it was less than obvious.

I will see if I can find it

Have a look at this link and see if it helps. There were updates over time that changed things a little bit but the instructions should hopefully hold true for you as well. I remember being really annoyed by this at the time

1 Like

Yah. FWIW I really do wish that we could embed this level of detail in the ROCK instructions. It sucks that new owners (as I once was) have to troll the forums to find this answer. And it is crazy that the authors of the answer need to spend time trying to find and relink the solution. Yet another argument for having you & @David_Snyder have a more formal role in curating the documentation. We should have better support for ROCK & should reduce the number of platforms you can run core on in order to reduce complexity & increase velocity. <\soapbox>

3 Likes

Agree, I would happily have updated a set of instructions for this.
As it was bookmarks work well, but some posts get a lot of visitors and updates and these can be lost in the noise.

You have said you checked Secure Boot and Modern Standby settings. But have you reviewed the SATA mode?

SATA Mode is set to Optane Mode in BIOS.

Legacy Boot isn’t allowed when in Optane Mode.

1 Like

If getting out of optane mode doesn’t work, one of us can send you an older bios file that will work.

It sucks more that rock (doesn’t yet) support uefi.

4 Likes

More work maybe but also if you’re done mucking with the bios here is how I would solve this…

Install a hypervisor on the NuC. Install ROCK in a VM (the VM will support legacy boot).

Now, you’ll be maintaining two things, the hypervisor and ROCK, but a thin hypervisor kind of maintains itself as well as ROCK. This install path would put you squarely in the unsupported tinkering / MOCK world. You’ll also need to make sure you’ve got the network set-up properly for the VM or you won’t find any endpoints. Another option, run one of the Docker ROCK containers.

Just a suggestion.

Or just use Windows until ROCK supports UEFI

Everybody, a big thank you for your suggestions.

ROCK is installed on my NUC10FNH with the legacy boot mode enabled.

My screenshot notes on the BIOS settings and the installation document can be found on WeTransfer - Send Large Files & Share Photos Online - Up to 2GB Free (for the next 2 weeks).

5 Likes

Really glad this worked out Dominiek!

I’m going to ask @danny again if any chance we could get some folks who are really good writers and well versed in the architecture to add a handful of really high value articles such as “ROCK bios settings for UEFI / legacy” that are the most common and the best settled to the Roon / ROCK official support documentation.

I’m a huge fan of using forums extensively and the community approach overall, but for these “most common issues”, I dearly wish we could have a “single repository” to point people to instead of the “it’s on the forums somewhere” / “just ask around” approach.

The folks who I think do the best job are @David_Snyder and @Michael_Harris but I’m not trying to sign them up. Just that I know we could be better off by doing a handful of things once instead of again & again.

3 Likes

What was the final answer to get Legacy Boot available for you?

I was pretty sure it’s in the document that you and I shared.
I had the same issue with my 10th gen Nuc last year, but accept that the BIOS changes things, as it was different before I did mine.

If not that @dominiek_cortebeeck can you share back the screenshots back into the thread for the next group.

A combination of a few things. It is all in the PDF at WeTransfer - Send Large Files & Share Photos Online - Up to 2GB Free with the screenshots

In short:

  1. verified that the SATA mode selection was AHCI (make sure the SSD can be found)
  2. power settings advanced / sleep type support is Legacy S3 standby (the default new Windows UEFI settings sometimes conflict with Linux AND this will allow you to click on the legacy boot mode later on)
  3. secure boot is disabled (to allow non signed Linux images to boot)
  4. save the BIOS setting and power off (for 10 sec according to 1 foru0
  5. in boot priority/legacy boot; enabled
  6. Mark Boot USB devices first (in case reboots from the flash image is needed)
  7. save settings
  8. power off
  9. plug in USB stick
  10. power on with the boot selection menu in the UEFI
  11. select the USB stick
2 Likes

Thanks for sharing that.
These things tend to get lost so it’s great to have something more recent to point back to.
Especially as newer BIOS updates tend to change things

I have bookmarked this to share 2ith the next person who has this isd6.