ROCK: Internet Radio gives "Transport: Failed to load media" error [solved - missing codecs]

Hi, anyone having problems with playing radio after ROCK install and restore of dBase. All my radio stations report ‘Transport failed to load media’

This worked fine on my Linux install and Windows 10 install on the same NUC.

1 Like

No… Cannot replicate:

I couldn’t even add a radio station to ROCK which was working before.

Looking into this…

Just adding data (not implying you guys don’t have problems): just added a station for testing without problems:

Just to let you know, I did a vanilla install of ROCK and tried to add several stations and it comes back saying it cannot find a radio station at this URL.

@NickB are you able to go to settings-> account and see info? Just checking to see if it’s an https issue

Added just fine:

PS: @danny – if you want me to stop replicating and shut up – just tell me. :slight_smile:

Hi Danny, yes if this is what you mean.

Same here.

My problem is the same as Nick’s. Are Scolley and Rene having a different versions of ROCK?

This short after release, I think alpha and stable ROCK are synced up. But whatever the case is – @danny is on it. And that’s the best news you could get. :wink:

OK just for my sanity I have re installed Linux server and roonserver on the same NUC and bingo, all is working again.

I’ve updated my ROCK OS to v1.0b72, still the same problem on adding new station. I restored my previous radio stations to Roon, though radio stations were displayed, none of them can be played stating address has been changed.

Tried again and get error message saying “Transport: Failed to load media.”

Using Sonos, the same radio stations can be played. So, it is not the address issues.

Hey @NickB, @hk6230 – can you check the web UI and confirm whether you’re getting a message there about codecs?

Like this:

Yes, I do.

Ok, well I’m guessing that’s the issue :wink:

If you follow the instructions when you click the “?” you should be all set.

OK, everything is working now with the codecs installed. Thanks.

Hi Mike, can’t check as have gone back to my Linux server install with Roonserver on and it runs faster (I believe) so will stay with that.