ROCK - Nothing But Problems - Back to Windows Zero Problems [Solved by OP]

Since I have installed ROCK it drops out, stops playback ‘waiting for Roon core’ and so on

I have a 12th Gen NUC (i7 32GB, M.2 500GB) connected to a Synology NAS

Put Windows 11 on it. Zero issues. Re-installed ROCK issue after issue. I’ve seen others with the same issues too, first it was due to being in the beta group. Left that and it was OK for a while.

Yesterday ROCK played ALL DAY and zero issues. Today, within 10 minutes 20+ issues

I wanted to keep ROCK but sadly it’s back to windows for me as I just wanted to listen to my music

I have a similar issue since I transferred Roon from my NAS ( Synology DS1513+ ) to a brand new NUC12WSKi5OPA and installed ROCK. It did work OK for a while and now it continuously drop out.
I believe to be a network issue but last night I used my Tidal interface directly on my NAIM UNITI2 without a glitch.
The NUC , the NAS, the Naim are all hardwired.

Should I drop ROCK and install Ubuntu on the NUC for a more reliable experience?

I’ve been using Rock for a day or so and I don’t have issues. Matter of fact it even has better sound quality than my Mac mini did.

1 Like

In my observation and experience ROCK just works for 99% of users. But sometimes synergy creates problems. Many NUC users swear by Ubuntu or other Linux flavors to run Roon Server. They say it’s easier to maintain the NUC with Linux tools and Roon runs just as well. I say do what you need to to make it work. Good luck.

1 Like

Have your music directly connected to the NUC and test again. Zero problems here.

1 Like

I used to run Roon on a NUC & found the memory usage would creep up until it became unuseable, needing a reboot.
I installed Debian 12 and the server software & it is fine now, I use PEQ, crossfeed, volume levelling & have no issues at all.
If it’s ok running Windows & you’re ok with at, I would just use Windows.

1 Like

This is an interesting issue. I went specifically with ROCK because Linux release distros (Inc Debian) would always seem to give some sort of issue. I run mine on a Dell R220 with 32GB ram. Currently at 86 days uptime (only due to having to power down for some maintenance on other devices in my rack) - before that it was well in to the hundreds of days. So what’s different here?

Was this ROCK and if so how did you know what memory usage was?


1 Like

@DSD_Fan , based on Roon’s known issues with the 12th Gen NUC, perhaps you should consider the 11th Gen instead? I realize you’re not using HDMI, but… the 11th Gen has zero playback issues… just a thought.

Yep, done all that. Works flawlessly on W10 and W11

Yes it was ROCK and I can’t remember how I knew, it might have just been the symptoms of the system, they went away when I installed Debian and ran Roon that way.
I had only had Roon I guess for about a month or so at that point, I think I became a subscriber in August 23.
So it wasn’t that it was an old often upgraded and updated installation.
Anyway, it’s fine now.

No idea, I just know my NUC, only a cheap I3, runs Roon and Plexamp server without issues.
Right now it’s reindexing Plex, doing sonic analysis on my library as I moved the location of the files, so cpu usage is higher than usual
I no longer use Roon for local files, just Qobuz and Tidal, right now I’m listening with my Poly Mojo2 combo using crossfeed and PEQ and it is responsive as normal.

I disable disk swap and force it to use ram.

Ps I reboot weekly after applying updates.

So, installed ROCK again. Works great for a few days then starts to drop out. A reboot doesn’t fix it. But a reinstall does. I do that and it works great for days but then develops the issues again. So looks like a memory issue like Grasshopper stated.

Now, if I could only know how to install Debian 12 and setup Rock on it :slight_smile:

You install Debian and run Run Server

Debian is about as easy as installing ROCK as you build a similar image then Debian’s install menu takes you through the install. You’ll want server not desktop. Then follow the instructions for Roon Server.

1 Like

I have had exactly the opposite experience. I ran a Windows 10 core for 5 years and the wait times for the core were getting longer. (Old hardware?).
In November I bought a new 11th Gen NUC I7 and it has performed flawlessly since with no need to reboot.

Well, I have FINALLY sound the cause of the issue. Nothing to do with Rock or Windows :slight_smile:

So, prior to moving to Rock (and a new 12th gen NUC) I have a full PC running Windows (i9/128GB) no issues at all. So under settings in Roon and then library, I had changed the ‘background audio analysis speed’ to 10 cores, and there was no issue on that setup.

Now I’ve changed that to throttled and everything is playing fine. Before I’d get a few days before it would play up. Now I am on almost a week and ZERO issues so far (very happy)
I do have the ‘On-demand audio analysis speed’ set to fast still. But can change that if needed.

Anyway just wanted to let you know that all is good now with Rock on a 12th gen Pro NUC (64GB and i7 and 500GB M.2 connected to a Synology NAS)


FWIW, there’s no point reinstalling ROCK. Neither the OS nor Server “change” during playback and cause this issue. As already discussed…

Correct. It was the background analysis set too high was the cause. But never checked that (thought it would reset anytime a new OS was introduced but no.
In saying that, the way it processes must be different on Rock to Windows as Windows had no issue set to 10.

Anyway, issue resolved and this thread can be closed.

Great that you have found the issue and thanks for posting the solution but I suggest that you change the title of the thread to something less misleading regarding ROCK installs.

I’m unable to change the title