ROCK now on NUC --How to add Codecs?

New NUC 313kit as recommended by Roon. And using a macbook to flash to USB drives. USB drives are set up in ExFat. I think I have been successful in flashing the Rock setup to a USB. But after trying two USB drives and reflashing the file several times, NUC does not see a USB drive at all. I looked for an updated Bios at the Intel site but did not see one for my kit, so I have done nothing with Bios. I am following the directions at Roonlabs.com. Can anyone help? Thanks

I just went into bios and under ‘advanced’ > ‘boot’ it shows UEFI Boot Priority and listed under “Boot Drive Order” is UIFI: LAN: PCE IP4 Intel® Ethernet Connection (6) I219-V. It is listed twice. On the right side of the screen is “Legacy Boot Priority” and under that is “Legacy Boot”. Under “Devices” > “SATA” is listed the SSD drive. Under “Devices” > “USB” is listed USB Legacy and the box is checked.

After reviewing what Haakon when thru in an earlier thread I have somehow managed to get the ROCK software loaded. I can access the NUC at its IP Address and I come onto a page that says everything is working fine BUT “Codecs are Missing”. I am trying to follow the instructions for adding the codecs and I have the needed file downloaded onto my macbook. The instructions seem to be telling me to go to the page that I am on --the page that comes up at the NUC’s ISP Address. But on that page I see no way to get into a place to deposit the codecs, I just have this one page. Can someone tell me how to get from this page to the place to deposit the codec file?

You have to copy those files in the codec directory.
Connect to your ROCK machine with your mac (Network) and copy the files there

Hi – I am trying to find the codec directory. The instructions say Finder>Go>Connect to Server> smb://ROCK/. This does not go anywhere. By using the NUCs IP Address I can get to the page that says “MISSING CODECS”: ! But I see no way to get past that page.

The NUC does not show up under networks. But I can access it via the IP Address

Both ROCK and the Mac should be connected to the same router…under NETWORK you should be able to see your ROCK…connect as guest

Try to reboot both of them

As a side note, to get to the actual ffmpeg file you might have to unzip it twice.

Try using smb://ip address/ with finder.
Accessing via web browser and ip will give you the web interface.

You are getting to the Web page which is not where you need to be. ROCK will share the data and storage portion of its OS drive over the network and you connect to it, like you would a shared drive on another computer.

I got the ROCK now showing on network. I think rebooting router and NUC did the trick. Thanks M. Matte

1 Like

Yep this is strange. I have tried twice to unzip the file and it still wont unzip!

The built-in archiver in macOS does not handle tar.xz files well. You can use a tool like The Unarchiver for extracting the file.

1 Like

Yes, I use 7zip to do the unzipping, but, I’m not sure that is an option on Macs.

I think I got it unzipped and then put it into the DATA file and then rebooted the NUC. I can find ROCK on network, click on it, then click on the DATA folder and it says “operation could not be completed because original DATA folder cannot be found”.

Ok I tried using the smb://ROCK/ address and it worked this time?! And asked for the firs time "sign in as … " and I picked guest. So not i can get back in, and see there is a data folder and the in the subfolder “Codecs” there is the file I downloaded and unzipped. But when I go to the NUC IP address. This page still comes up:

Notice it still says the Codecs are missing.

Can you share a screenshot of the contents of the Codecs folder? Be sure to just copy the ‘ffmpeg’ file.

OK now the flag that said “Codecs Missing” is gone away. (Dont ask me why?!). I then went ahead into the Roon software and “selected core” as the NUC. And now it is going thru some setup routine…

1 Like

Eventually you had to reload the website to see new content.