ROCK NUC8i5BEK installation issue

Hi I am having an issue installing ROCK on an Intel NUC8i5BEK. I have followed the installation guide on the ROON website but cannot Boot from the USB stick. The BIOS is set to Boot from UEFI and will not let me ‘Uncheck’ the UEFI Boot option or enable the Legacy Boot option!
Is this a compatibility issue with this model of NUC?
Does anyone know how i can Uncheck the UEFI setting (it is currently greyed out).


If I recall you need to go to the Advanced tab, then Boot>Boot Configuration?

I had the same issue installing ROCK on NUC8i5BEH. I have followed the installation guide, but got a hard time getting the NUC booting on USB. Some of the menu points described in the ROCK installation manual was not working - fx the sequence of boot between devices. But suddenly it worked, at it was installing Roon ROCK.

I have absolute no idea what caused the installation to work. But I have later on issues by reading USB sticks / disks via USB.

Maybe there is an issue with the 8. generation Intel NUC?

I have today installed ROCK on an NUC8i7BEH that was delivered from SCAN yesterday, and switching from UEFI to Legacy Boot was simple and intuitive, and I can’t really remember exactly what I did, but I definitely clicked on Advanced button in the default window (yes it was not possible to un-check Boot from UEFI in the default window), and from there it was no problem. I did not need to update the BIOS as the machine was on 051 already.

1 Like

This actually makes sense to me (regardless of whether it’s by design or a bug of some sort). When I go into BIOS setup the first thing to do is to enter the Advanced mode.

If I remember correctly (as it wasn’t difficult or non intuitive, I did not really think about it as I was doing it) after clicking advanced, the page displayed was two panes, the left for UEFI boot settings and the right for Legacy, and clicking the tick box in the Legacy side set it on and removed the tick in the UEFI Boot side…

Thank you for all your input. Still not having any joy. After trying all the above still not got the option to ‘uncheck’ the UEFI boot option. I will contact Intel Support and see if they can resolve the issue.

Thank you.

Tag @support

Hi @Ian_Fraser,

Can you share some screenshots of the options you are presented in the BIOS? You can use these instructions to upload screenshots here. Have you made sure to follow the BIOS Configuration Guide and set your BIOS to factory default settings first?

– Noris