ROCK on NUC: Linux commands

I am trying to put ROCK on a brand new NUC (i5, 8 GB RAM, 128 GB SSD).
But Linux kills me. What do I have to do with:

  1. Unmount any directory your flash drive was mounted to.
  2. Run sudo dd bs=10485760 if=factoryreset.img of=/dev/sdb (replace “sdb” with the appropriate device name, and factoryreset.img with the path to your image file). This can take a few minutes, depending on the speed of your USB flash drive.

And this is the easy way….

Thanks for helping me

Those commands only apply if you are trying to achieve the end result using a Linux machine don’t they? On a Windows laptop all of the preparatory steps were just click and go.

As @Henry_McLeod mention, Those are the linux instructions… What is your primary OS @Rudo_Meijer?
There is a step by step for Windows, Mac, Linux here:

Yes, I see now. It must be click and go…
Roon is no on the SSD, and now there are codecs missing.
So still no working NUC,…

You need to drop the ffmpeg static binary in to your data partition as instructed on the kb article:

Yes, but I cannot decompress ffmpeg-release-64bit-static.tar (1).xz
There seems a fault in the file…

Re download it from:

I just downloaded it and had no issues.

1 Like

It will work without the codecs but you may not be able to play AAC files etc.

The ffmpeg file is double compressed. Try decompress all or decompress it twice. That should give you a list of files. Drag and drop the file called ffmpeg.

The link at the end of the step 2 in “How To Add Codecs: Step By Step” is not woking for me.
2. Connect To Roon OS - Roon OS exposes a shared network folder called Data. You can access this SMB share by following the instructions here here.
When clicking on the link it gives me this message “Safari cannot open the page because too many redirects occurred.”


You connect to it via network shares. Under Mac OS

Go -> Connect to Server -> smb://rock/data -> Connect

You can also use the IP of your ROCK server instead of the mdns name.

Thanks a lot Fernando for providing the instruction. Still I hope Danny fix the link. I assume that there are instructions for Windows too, aren’t there?

@Jose_de_los_Santos, crap I just notice what you meant…

The actual link is:

Not sure why there is a “e” in there. I thought @danny fixed this…

Edit: Edited my post and fixed… and again… with dannys reply…

Fixed link.

1 Like

Great, thanks again Fernando!
Thanks Danny, that was fast!

1 Like

I do have a working ROCK on my new NUC now!

My old and favourite Total Commander ( just could not decrompressed the file…

No Roon is exploring my NAS, and Ijust find out that my (to old?) iPad cannot be used…
My iPhone’s display is to small for convenient use.

Nevertheless, thanks for helping.

1 Like

Same problem here. Maybe a Windows user could decompress and post the ffmpeg for us linux users?

If you’re on linux then you don’t need no stinkin’ Windows. :slight_smile: You just need the “xz” command. I believe it was installed by default on my distro, but I don’t remember. You probably know to do a “man xz” for how to use it.


I do, but the problem persists. frustrating!

Have you tried:

sudo apt install xz-utils

tar xf ffmpeg-release-amd64-static.tar.xz

The unpacking did work - it was apparently an issue with share mounting - you need to use the -t cifs option