ROCK shows following error: "Failed to load device state (status: 0). Please refresh." - [Resolved - SSD Issue]

I am experiencing an issue on a NUC5i3 with 16GB RAM and 360GB m2 SSD. Codecs are installed and running ROCK on the most recent BIOS version. When trying to access the roon interface via browser the folloing message is shown:

Failed to load device state (status: 0). Please refresh.

I actually switched from Win10 to ROCK due to some similar issues, but I assumed it was caused by Win10. The NUC just randomly froze although I could move around the mouse. At appears that this is now also happening with ROCK.

Any way I could identify or you could also help me with identifying the issue? Is it the RAM, the CPU or the SSD? Or maybe something else?

My issue was bad RAM.

ok, but how did you figure that out or which symptoms did you witness?

as i described above. I had random freezes, where I could still move the mouse cursor but could not run win task manager and the only solution was a hard reset. this behaviour also did not change when formatting and installing win10 from scratch.

strangely enough the NUC worked for installing win10 and installing few apps such as KoDi and Roon. does this sound like faulty RAM?

It doesn’t necessarily say it isn’t faulty RAM either. Flaky RAM is a difficult find without using a RAM diagnostic program. Which is the answer to your other question, how do I tell if it is the RAM. Some BIOS’ have a RAM test option.

I actually did the test when i was running win10 on the nuc and did not find any issues (via Windows Memory Diagnostics utility)

Anyways, I will pick up a 4gb crucial RAM module from a electronics store for 10€ (second hand from a showcase device) for testing purposes and will see then.

I also checked HDD and CPU health and everything looked fine as well, so I really don’t know what is going on…

so, i picked up the RAM and it turns out that it wasn’t the RAM.

however, when running ROCK it ran for approx. 2min until Roon Server just stopped.

So I went to the NUC for hard reset, but it seemed that when pressing the power button for a short moment, ROCK initiated the kill sequence as I saw the command lines on the screen popping up. So apparently, the NUC did not freeze.

Any idea what else could be the issue?

1 Like

Thank you the report and sharing the observations you have made with us @k1282, the insight is very appreciated and sorry to hear of the troubles here.

Moving forward, I would like to get a set of your Roon logs over to our tech team for analysis to see if we can determine what is causing this behavior with your setup. In light of this may I very kindly ask you to use the instructions found here and send us over a set of your Roon logs from the NUC hosting ROCK via a shared dropbox link.


Hi Eric,

thanks for the offer.

I switched back to Win10 for testing purposes. Once I finish that and do not find a solution by tomorrow, i will install ROCK again and send you the logs as requested.


The things we do for testing:

i just couldnt wait 1 week for this stupid proprietary intel sata power cable, so i hooked up the power part of my old ssd to the PSU unit o an old desktop PC, just to test if the m.2 SSD has issues despite all the diagnostics I ran that told me the SSD is doing fine.

OK, I guess I did enough testing. The test with a 2.5" SSD was succesfull (runnning since 2 hours without any hickups).

It must be my precious Intel m.2 360gb SSD that is not working properly, despite alle the diagnostics I ran that told me that it is fully healthy…

Topic can be closed

1 Like

I’m glad you got it sorted. But, I understand your pain. It sucks when something seems to be functioning fine in diagnostics, but, really isn’t.

This topic was automatically closed after 29 hours. New replies are no longer allowed.