ROCK SMB access from Chromebook

Is there a way to get my Chromebook to see the SMB file share on my Roon ROCK?

Apparently this is an issue with ChromeOS where it cannot see or connect to shares offered with open access, i.e. no username/password. There’s a solution for Windows-based servers - create a new passwordless user on the server and add it to the fileshare permissions, but of course I can’t do that on ROCK. Any pointers would be appreciated.

1 Like

Any link to this issue? I don’t have a Chromebook but googling found nothing about this except one article about accessing a NAS with a Chromebook that positively stated “if share access on the NAS is anonymous, don’t enter a username/password”

I’ve lost the original link, but I’ve since found this page that suggested an extension on the Chrome web store called “File System for Windows”. I’ve installed that and it seems to be working fine but, like the OP on Reddit, I’d prefer a native solution.

1 Like

Hi @David_De_Silva

Welcome to the Roon Community

Just a fellow Roon user here.

I believe you’ll have access to Google App Store. If you do, search for Cx File Explorer. Or try the link below.

Let us know when you get that far and I can assist you further.

If you can enable SMB file share in the Services menu of the Files app you can connect to an SMB share. I use it for connecting to a folder on the NAS. Is that what you’re looking for ?

1 Like

That’s the option I was hoping to use, but ChromeOS won’t connect to anonymous SMB shares.

@Menzies suggestion has worked, but again requires the installation of a third-party app. There’s more than enough options to fix my problem - just not in the way that I had hoped - so I’m marking this as ‘solved’.

1 Like

I could be wrong, normally am, but should this not be


Not in SMB parlance. The use of backslash harks back to the old days of MS-DOS. But I did try it anyway, just to be sure… :slightly_smiling_face:

I guess I was hoping someone would know of an internal RoonOS username/password that could be used to connect to the SMB share, but I now have enough workarounds to keep me going.

1 Like

In Cx File Explorer, for a manual SMB share I use /, if I use \ the share cannot be added.

IIRC, been a while since I used Chrome OS, but / worked as per @airdronian advice in Files.

I just like Cx File Explorer though

To muddy the waters a bit, I just connected to the SD card on a Pi without credentials.


Do you have the Linux Development Environment enabled ? Perhaps that is providing this ability.

I selected SD Card and clicked “Add” from this screen and it mounted the share.

I will have to check out Cx File Explorer.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.