ROCK updates every time I start up Roon

Every time I start Roon I am advised that an update is available. I looked at the details and it’s always the 2.0 build 1148 update for ROCK. This is just a nuisance and not a catastrophe. All I do is run the update and I’m good to go. Has anyone else faced this issue? How do I get ROCK to update permanently. FWIW, I did set ROCK to automatically download the update, but I still get the advice screen. Thanks for any suggestions.

looking…

its not responding to me… can you give it a reboot? i fear you have a failing SSD, but id like to look further at the logs

I just rebooted. I fired up Roon again and was advised to install the update. If I need to replace the SSD, does this essentially mean I’ll be doing a full ROCK install? Because if so, I’ll upgrade my NUC to an i7.

how did you reboot? the box is doing something, but it shows 107 days uptime

maybe pull power, wait a few seconds, then power it back on?

I did a reboot from the browser console. I just did a hard reboot by pulling the plug. Let me know if the hard reboot did any good. Thanks so much.

I’m not seeing it at all now… I think that SSD is probably not doing good… Do you get anything on that HDMI?

Roon OS runs out of RAM mostly, so it rarely touches your SSD. It was probably up for some period just out of RAM, but rebooting needs to hit the SSD.

Yes, but you won’t need to update anything but the $20-$30 component. Note that you can go i7 at any point by just swapping the SSD from old to new.

1 Like

Danny, the hard reboot seems to have solved my problem. I’m not being asked to update anymore. Thanks for the suggestions. You can close this topic now.