Rock USB audio output

I just installed a Roon Rock on an Intel NUC8i5BEK2.
It seems to have installed well, except that I cannot figure out how to get sound out of the USB port on the Rock.

Various audio devices are connected to the Core, but none of them seem to be the USB port.

The analogue and HDMI0 will play through other devices.

Audio is enabled in BIOS and I have tried with and without HDMI audio enabled.

I am plugging a Chord Mojo into the USB port, but it doesn’t light up.

Any suggestions for how to proceed?
Do the Mojo or the USB audio require special Linux drivers, and if so, how to I install them?

Now after plugging and unplugging the Mojo repeatedly, it suddenly worked.
Hopefully having found it once, it can find it again in the future, but it seems a bit hit and miss.

Unless you particularly want all those inputs you can turn them off in the BIOS.

Yep, I keep any audio devices unenabled unless using them.

I only enabled them in case one was a pseudonym for the USB socket.

It is no less logical than plugging and unplugging the Mojo in exactly the same way, hoping for completely different outcomes (a sign of insanity). Except it worked!

Next time you run into a similar problem, try a different USB port and a different USB cable.