ROCK - Watched Folders not updating

So have moved my Roon Core from my Laptop (Win7) to running on a NUC with ROCK.
My Music Library is stored on a ReadyNAS Ultra 2+/Pro 2.

When Roon Server was on Windows any update to my Library, in additional files or changes to album artwork or metadata would be instantly picked up by Roon Core.

However with Roon Core on ROCK running on the NUC, the watched folders mechanism does not seem to work, in that to get the Library to reflect any updates, I have to manually request a Forced Scan, it does not automatically detect any changes.
No other settings in the Storage settings have been adjusted since migrating from Windows to ROCK.

I had this with Asset R5 running on a RaspberryPi under Raspbian accessing the Library on the NAS. In the end, they had to introduce a ‘Forcibly Scan Library’ time setting, which I have set at hourly with a check every 60 minutes.

Storage settings

On the target ReadyNAS I have both CIFS and NFS enabled.

I use an NFS mount from the RaspberryPi to the NAS, as there was a speed and buffer advantage over CIFS on a Linux-to-Linux system.
How does ROCK make its mounts and its monitoring of resources on mounted drives - SMB and iNotify?

So, on the target ReadyNAS platform, /proc/sys/fs/inotify/max_user_watches is at 8192

Thanks, Simon.

Same problem with my Synology NAS and ROCK. I had this issue before when I was using a NAS and a Mac Mini as core. This is one of the disadvantages of using a NAS, they all don’t talk well with Roon.

Roon currently re-scans all shared folders every 4 hours. We plan on making this a user configurable setting at some point in the future, so that you can make it more or less frequent, or disable it completely if you would like.

We do use SMB to mount network shares, and iNotify to watch for changes. I was under the impression that the /proc/sys/fs/inotify/max_user_watches setting on the system watching the share was what mattered, not the setting on the NAS. I haven’t actually tested that though, so I could easily be wrong there.

You could try increasing the setting on the ReadyNAS, 8192 is quite low. For iNotify to work one needs to watch every directory/file in the whole tree, which appears to be maybe 80,000 things on your system. I will be surprised if this helps, but it probably can’t hurt to try. In particular, I don’t understand why this setting would matter if Windows manages to get change notifications from the ReadyNAS and Linux does not.

Other than settings tweaks like this I’m not sure what we can do differently. We rely on the OS to reliably inform us of changes to the files, it’s difficult to do better than “scan every hour” if the OS isn’t giving change notifications.

Thanks for your response. I wasn’t aware of the 4-hour rescan functionality, as I didn’t need it when the Roon Core was part of the Roon Server on Windows 7 and the detect changes function on the remote NAS worked perfectly on all items - artwork, metadata, new/deleted files and any file changes.

I did a number of investigations around the iNotify settings on the ReadyNAS for Asset R5 on the RPi, and it did not make any difference there, and when the ‘Forcibly Scan Library’ in X minutes setting was added, I just set that at 60 minutes and have left it. In fact, whatever it reads can remain in the cache of the NAS, as during the rescan it doesn’t wake up sleeping disks if there are no changes to be read.
Plus any system level changes made to config files, outside of the GUI on the ReadyNAS are reset and overridden when you reboot the device.

Furthermore, the RPi is on a separate switch in the Living Room, close to my Network Player (a Naim NDS), so that the last step between UPnP server and Render is on the same switch and ‘local’, particularly as Asset transcodes compressed PCM formats to uncompressed WAV. The NAS, is one of 4 NAS units in the Study, with the others providing Backup duties, plus serving A/V content etc. So I was hoping that Roon Core running on NUC-based ROCK on the same switch as the NAS, the library auto-detect would have worked.

So, could I request a configuration rescan setting in Roon, so it can be set at 60 min, which keeps the Music library up-to-date, and if an update outside of this, a manual rescan can be forced.

Thanks, Simon.

I just migrated to ROCK and have this same problem with my watched folder on a Synology NAS. Previous setup was Roon Core on a Win10 pc connected to the same Synology NAS and changes to the folder were immediately updated.

On my new ROCK install, the watched folders don’t get updated no matter how long I wait. I have to force a rescan for every change I make.

I am facing the same issue, and I have a 4TB 2.5" WesternDigital SATA drive (spindle) connected to the NUC directly via USB.

Adding folders, they do not show up in a timely manner (did not wait 4 hours).
When roon was running on Windows 10, (same drive connected directly to DELL via USB) the update on new files was almost instant.

The drive is not configurable, but I know it is spinning as I am copying and running other operations against it.

Odd :frowning:

Yep, only on Windows 10 you get automatic and instant updates.
With the NUC you have to force rescan.
It’s a minor thing… It’s part of my routine when I add a new album. Copy to backup, copy to NUC, rescan, play.

1 Like

@Iftach_Landau, this is very strange. I have a USB3 disk connected directly to a NUC running Roon Core on a Linux distro (not ROCK) The ‘Watched Folder’ in Roon is working fine. I do have the disk formatted as naitive Linux ext4 and mounted as /dev/sdb… Maybe your disk is NTFS as you also used it with W10? I do not think a Linux OS can build a inode table for NTFS. @ben?

EDIT: I had the same problem as the OP @simon_pepper with music on a ReadyNas Pro2 share. Watched Folders did not work from a Linux NUC. The directly attached USB drive fixed this. Same as an extra internal drive on the NUC would

1 Like

Setting the ‘Automatic Rescan Interval’ to 1-hour works now for me.
If I need additions present in the Library immediately, I can ‘Force Rescan’ if not anything new or change is picked up in due course. This is the same on my Asset-based UPnP server configuration.
My ReadyNAS Pro2 has 2GB RAM, so once changes are indexed, any subsequent scans will be from the cache and does not wake the discs if they have spun down.
Thanks, Simon.

1 Like

My NUC does run ROCK, and has a 4TB WD drive directly attached via USB3.
The drive is formatted as exFAT per Roon recommendations

I am now manually rescanning, as noted.

BTW, when you open the control software on a PC or phone, is there a latency until the core is recognized, then active?
Was hoping the ROCK will solve this; perhaps this is a work as design.
I think of having a cheaper phone/tablet connected to wall power and not close the control app

A few seconds, as connection is established, yes.
Also if the discs in the NAS have spun down, when a track is played there can also be a delay, as they spin back up, before the tunes come forth.
Not much different, to taking the lid off the Turntable, switching the Phono-stage to Battery power, taking the record from its sleeve (anti-static inner sleeves of course), clamping to the platter, taking the stylus guard off, setting the input & volume and dropping the tonearm.

1 Like