rooDial a Wireless Volume Knob for Roon with Microsoft Surface Dial

And yes, you can control one zone with multiple Surface Dials.

I’ve had a long term but intermittent issue with the dial that has at times been driving my crazy. It basically worked perfectly until I had friends come over - which of course made no sense (hence driving me crazy).

Finally I realised that I was using the ‘display’ Roon feature and screen sharing to my tv - to put the track / lyrics on tv when friends came over.

And it was this, at least for me, that breaks seems the RoonDial connection.

Anyone else have this issue?
Found a solution?

I have been using rooDial for a while now and it’s always worked perfectly. I have been enjoying the fact that when I use the dial my entire paired zones volume (5) goes up and down; only the endpoints that are unmuted when turning volume up or down react. Muted zones remained muted despite the use of the dial. Beautiful! Since the last couple updates (I don’t know if it’s a Roon update or a rooDial update) as soon as I turn the volume up, one of my end points unmutes and the volume goes up in the other room. Only my raspberry Pi with a DAC Hat unmutes. All my other end points (Bluesound Nodes and Rpi with digihat) stay muted. This never happened before and I don’t know how to fix it. Does anybody know why all of a sudden my endpoint with a DAC Hat (justboom) Will not stay muted when moving the dial? Thanks!

Hi @Eric_Leport,
please try to boot all devices and retry.

I haven’t changed anything in this corner of rooDial during the latest updates.

Best DrCWO

I have installed on a Pi 2 Zero W with the SD Card image supplied, configured in its website and licensed and enabled the extension in Roon.

When I try to pair the surface dial it just flashes the LED and doesnt pair, still shows unpaired in roon extension - You mentioned previously a beta with a “repair” option on the website - can you send alink to that please?

Have you tried to pair the Dial with something else before pairing with rooDial?

If yes search for “Batteries” in this thread here and you will find my hints on how to proceed.
In any case you should shut down the device you paired the Dial before. Otherwise the Dial will always try to pair to this device.

Best DrCWO

Hello DrCWO.
Welcome back and home you had a good vacation.
When do we expect the update when the disply can also be connected to the rooextend.

Holiday was great!
I had a six week and 2000km Mountainbike trip from northern Germany to Rome in Italy. Only dirt trails :grinning:

Regarding your question I posted something here:
Extension to display cover art on a sense hat attached to a Raspberry Pi - Tinkering / Roon API - Roon Labs Community

As I must be out for a business trip the first weeks of July you can expect the v2.3.0 at beginning of August. As you can see in the linked post it is already up and running in my study :+1:

Best DrCWO

Thanks, the only work around I found is to go in Roon and set the device volume control to “DSP volume” instead of “Device volume” I lose about 50% volume by doing so and 80% of the volume controls happened at the end of the volume slide control but at least it doesn’t unmute when I move my rooDial in the other zones.

The Surface Dial connects to the Pi via Bluetooth, while the Pi connects to Roon via WiFi

1 Like

or ethernet, which in my case has proved far easier to setup & is also more reliable.

YMMV of course.

Thank you for your help in getting me back up and running today.

1 Like

Is anyone having any issues with fan control when running RooDial? The fan in my case runs for about 15s before stopping and then immediately restarting, running for another 15s and then stopping and starting again and so on…

There are no settings for this exposed in the GUI that I can see and of course the default Pi usernames and passwords are not valid so command line access isn’t possible. Is anyone else seeing similar behaviour as surely this shouldn’t be normal and is detrimental to the lifespan of the fan?

Can’t help, no fan in my setup …

Nobody complained about that until now so my guess is that nobody has a case with a fan. Nevertheless i will be happy to help here.
Please drop me a line to info@definiteAudio.de and I will help with the credentials.

If you have found out what can be done please let me know so I can include your finding in the next release.

Best DrCWO

Hi DrCWO and hello to the community!
I’m new to the forum and not sure, if it’s the right way to reply to the opening message to post a question (haven’t seen another option so far). But ok, I’ll see, if it works.
I have tried to start your great project, it started fine, but failed in the end. I have the following message on the roon extend:


My roon core is a nuc 10, to backup I use the hard disk, on which roon runs und furthermore a usb-stick, which backups on different times. I don’t know, if it has to do with the usb-stick and why roon tries to backup the roon dial settings on an usb-stick and fails. Do you have any ideas?
Greetings
Thorsten

Hi Thorsten,
welcome onboard :grinning:

What I see here looks great. It means you successfully built up your Pi and installed rooExtend.

If you start the Pi, rooExtend checks if it can find a USB stick with saved license keys and will load them. If there is no USB stick you get this output which is also fine. Most of the time you don‘t want to restore license keys :wink:

So next thing to do is to get a license key for the Roon Extension you like to use and enter it in rooExtend. Doing this will enable the Roon Extension you were looking for.

If you have further questions this is the right place. Feel free to ask. All guys around here are very helpful if I don‘t find time to respond quick enough.

Searching for rooExtend you will find my other support threads, one for each of my Roon Extensions.

Best DrCWO

Hi DrCWO,
thank you for your quick answer. This step was missing, you`re absolutely right. Now I know, when it’s the right time to buy the license, so if you will have a roon-smartwatch-project for android, I will know, how to make it work fast :wink:
The functions of the dial work great, I have tested it in the next room, too, with no problems.
Thanks
Thorsten