Roon 1.3 problems on Mac

@support

Hi there. Frustrating experience. Tried Roon briefly in 2015, it was a work in progress at the time so I cancelled my membership and didn’t look back. Now, after all the positive reviews, I decided to give it another try and, because I was in a generous mood, I paid for a life membership plus Tidal for 6 months to get the full experience.

I set up my core on a QNAP TS-453 Mini and pointed it at one (!) album out of my several hundreds for testing. I have a late 2012 iMac QUAD i7 with 32Gb of RAM running 10.13.1, some Sony CAS-1 USB desktop speakers, a NAD M17 with the BlueOS module installed and other various bits and pieces but this is my system for testing. My toys are hardwired with CAT7 cables to a 300 series Cisco switch and the routing is done by a Draytek 2862AC.

The testing went well. The Tidal app worked, the BlueOS app worked, the Roon app worked and recognised the mac as well as the USB card (Sony) and M17 and could stream music without issues to any and all.

I didn’t play much because I was prompted to upgrade to the mighty 1.3 and this was the end of it. I can still open Roon and it sees my QNAP core, the Mac and M17 are listed, the Tidal content is visible. But if I try to refresh the Audio devices to discover my Sony USB, it just spins endlessly. If I try to play some content, no audio is sent to either the Mac or M17. The progress bar is frozen, nothing happens. The Tidal app still works well, as does the BlueOS app.

Checking the processor usage I see that Roon uses some 35% of my CPU to do nothing. So I suspect there is some sort of incompatibility with stuff on my computer.

I tried to look for similar problems on your forum but on several occasions I was redirected to a “you don’t have access to this thread” page while a bot messaged me prompting me to become a familiar presence on the forum to gain full access.

With no disrespect to the good, enthusiastic folks on this forum I have no time for forums or socialising and the only reason why I am here is because my 400£ investment is presently useless. For someone who paid a life membership I would expect at the very least full access to your forum, no questions asked.

Many thanks

Adding @support so they will get notified.

Hi @Bogdan_Delcea ---- Thank you for the report and sharing your feedback with us! The insight is appreciated.

Moving forward, based on the symptoms you are describing, at first glance this feels like something is could be blocking RAAT server (our streaming protocol). Can you please confirm for me that the mentioned iMac does not have any active firewalls or antivirus applications running on it. If it does, please disable these functions (temporarily) and confirm if this action triggers a change in behavior.

Furthermore, just to make you aware, the mentioned QNAP’s Celeron processor is a bit under our recommended spec for running Roon. Additional information on why this type of processor can lead to performance issues can be found here in our knowledge base and here, as mentioned by our CTO on the community site.

Lastly, If you don’t mind me asking, what links were you trying to access and having problems with?

-Eric

1 Like

Apologies for the misunderstanding here. We don’t limit access to posts based on the amount of forum usage–that is a confusing message coming out of the software that we use to run for this community site.

For a brief period, we had a Frequently Asked Questions area on this site. This section has since been removed–which is why you (and everyone else) cannot access those links. The content from that section has been re-worked and expanded into two sections on our knowledge base site:

The User Guide: https://kb.roonlabs.com/Roon_User_Guide
The FAQ: http://kb.roonlabs.com/Frequently_Asked_Questions

Unfortunately, while that old FAQ section was still active, some users posted links to the FAQ on this site. There is no straightforward way for us to re-map those links into the knowledge base, so those links are broken today.

Hi Eric, and thanks for your swift reply.

I was trying to access the “Uninstall and Reinstall Roon” thread which was the first thing that came to mind, after rebooting my Mac and my QNAP.

I tried to delete the app from Applications but the data, settings, account details are probably saved somewhere else because once I reinstalled the app I was back to the same status - logged on, QNAP core, M17 available etc.

I thought it may be the rubbish left behind on my Mac - I had a Naim NDS, a UnitiServe, I had a Linn DSM streamer, I had Sonos, I had Devialet Air, I had JRiver, Amarra, Dirac etc - and my MacOS hasn’t been reinstalled from scratch in a long time but that’s not something I have had time to do yet or will have time to do anytime soon.

The only protection running on my MAC is the native Firewall but Roon is allowed full access. I have just disabled it - no difference I’m afraid.

I know my QNAP is not up to scratch but, again, this is only a test system to decide whether the Roon / Tidal experience is worth the hassle compared to UPnP with Linn, Naim etc, also whether it’s worth investing in a MQA dac. That’s why I only have one album in my list. It’s just a demo for me to see if I prefer your interface to any of the above.

It looks like Roon has both the usability of my favourite Linn ecosystem as well as Naim’s album “booklet”. However, as nothing is perfect, the one negative for me is being tied up to a Tidal subscription which is not my cup of tea - looking at something as basic as Beethoven’s 9th I could only find a couple of rubbish versions. Their collection of classical is certainly not up to scratch. But that’s a conversation for another time.

In the print screen bellow you can see that my Sony USB sound card is active but Roon is frozen in “Refreshing” mode. Although it “sees” my default Mac sound card and my M17 it doesn’t send sound to either and if I try to play something nothing happens.

Many thanks !
Bogdan

Before 1.3 it was correctly detecting all my devices and sending music to them without issues.

I am happy to report that, following rebooting everything (no joy), disabling the firewall (no joy), reinstalling Roon on my Mac (no joy) and, finally, reinstalling Roon Core on my QNAP, I finally got it back up and running.

Although the Core was updated to 1.3 automatically and reported all was OK in green, there must have been some problem following the upgrade. Many thanks for your support.

1 Like