Roon 1.7 update mess up Qobuz albums/tracks

After the update to roon 1.7 I have several Qobuz tracks, albums not playing / showing / marked unavailable.

Artist: Paul Simon - Album: Graceland (25th anniversary edition) - Track: Diamonds in the soul of my shoes.
Search in Qobuz for Paul Simon and album is shown and tracks can be played
Search in Roon, Search for Paul Simon and Graceland album is not in the album list
Search in Roon, search for Graceland. Album is shown (no unavailable indications), but if I click a track to play. Pop-up 1 track playing appears, but nothing played. (current track just keeps playing, no further error or any other message)
Go to playlist in Roon where track from Graceland is included. Track is marked as not available.
Tried with other albums and tracks and several times found the same mess up of display, information, no play back etc. Adding the album to the library sometimes helps as well.
Most items could be solved by removing them from playlist and adding it again or adding them to the library. Some items remain with problems.
Looks like very poor object oriented programming where flags are not inherited, removed or overwritten.

Try logging out of Qobuz then log back in. Worked for me.

I suggest opening a support ticket/thread. I’m not able to reproduce any of your experiences.

Thanks - I lost hi-res streaming, but logging out/in fixed the issue and all resolutions are visible in the Qobuz/Roon setup page.

But the tracks skip…

I’ve had tracks skipping in both Roon and Volumio today.