Roon 1.8 (Build 880) Feedback Thread

“Playlists by Roon”? I love you, Roon. But I can’t overstate how much I do not and will not care about your playlists or your experts’ playlists as long as I cannot edit my own Tidal playlists in Roon. I spent years creating playlists in iTunes, and I’ve spent years recreating and expanding them in Tidal. Nobody creates playlists for me better than I do. Roon is a great way to discover new music and rediscover old music, except that I can’t add any of those discoveries directly to my existing playlists. I’m starting to think you just don’t care about us old Gen X mix tape makers.


But I don’t see an update for the Pkg that gets installed on my NAS

Seems like great new features. I noticed that when I tried to add a Qobuz album to my library, it just kept on spinning. When I navigated away and back to the album, I get a plus sign to add to library. When I reboot Roon, the album page shows up as a library album, but the album icon does not show up in “recently added” on my home page. All this is from a Roon Remote on my iMac Pro; my Roon core is a Nucleus.

Count me in as one of the chumps with a corrupt database. This sucks.

I’m sorry but no.

See the issue listed I have here Update to Roon 1.8 Build 880 corrupts my Roon Core database

Thanks, Simon. I checked out the linked thread and will monitor it. What a loss.

1 Like

Web display - I see the port number for web display changed to 9330 with 880 so got that sorted.
However, I’m now not getting full art - just the lower left thumbnail and the upper defocussed background. I’ve tried on a number of devices with the same result.

Anyone else?

(btw - otherwise all good with the 880 upgrade so far)

1 Like

Not getting many answers from Roon, but I’ll try again. As an example, the thumbnail image for Duran Duran is a logo. I looked in Valence and there are 24 accepted Avatar images, some pictures and some logos. What is the logic behind using a logo instead of a picture. And am I correct in assuming that these images are no longer under my control but what is displayed is whatever the community decides?

Yes, had the same experience. Many of the images I added to my collection are missing as well. A lot of them I kept in a folder so can re-enter them but as you say, wasted work (aka time).

I need a clean Roon 1.8 build 880 apk file for installation on my Fiio M9 player which I would like to use as a Room remote (the Fiio runs a customized version of the Android os but does not have access to the Google Play store so I need to download the file elsewhere and sideload for the install). Can someone point me to the file here on this site or somewhere else on the web? I am running the updated v. 1.8 on a Dell Windows 10 pc as my core. So far there have not been any problems with the core or with other devices. Thanks in advance for your help.

I think there’s plenty of room for the DIY crowd. I am just speculating on whether the options are too broad.

A great idea in the early days. But now maybe unsustainable.

Definitely seems to broad now.

1 Like

You know, I was being facetious, but maybe they should make Roon a hardware/software product with a choice of a Nucleus or pre-built and loaded NUC. No more “do it yourself.” Have a Windows/Apple version of the software available for a limited time for testing prior to ordering the hardware version. After all, how many people build their own TV? They would end up with 4 devices to support. Two Nucleus’ and two NUC’s.


Thank you for responding quickly to my request. I appreciate it.

1 Like

corrupt database, no audio devices, drives appear disconnected… SILENCE


Something has to change. These upgrades are brutal for some of our fellow Roonies… Rooners? Roonites?


Maybe more, smaller updates instead of less, huge updates.


I’ve been lucky and I’m loving the update. Suddenly I can stream at 24/192 to my Ropieee endpoints on WiFi! :slightly_smiling_face::+1: