Roon 1.8 on QNAP NAS

{QNAP TS453A/ Machine (Operating system/System info/Roon build number)
I updated my IOS devices first and then I found out that there is not an update for ROON 1.8 is available for my QNAP NAS.
So now I can’t acces my ROON endpoints anymore.

**QNAP TS453A, Cisco Meraki switch - Netgear switch - MOON 390 **


Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)


Description Of Issue


I am in the same situation.

EDIT: I was in the same situation. I launched the QNAP Roon app and i guess it was updating. Now it reads Roon version 1.8 build 753. Controllers connect and everything seems fine. Woot!

Update on IOS devices OK but Qnap cannot be updated. iOS 1.8 app does not work with 1.7 core, so no Roon operation possible right now. Does anyone have information on a 1.8 update for Roon on QNAP?

Hi everyone,

After a reboot of your Core machine is there any change?

Easy fix:

Log into your QNAP NAS. Go into apps and find Roon Server. Open it. Click on the little “box” icon in the bottom left and tell it to get/update Roon Core to latest version from Roon. Done.

1 Like

This worked for me! Thanks.

1 Like

Hi Shane_White, I’ve tried to click on the “box” icon but got stuck into this page. is there anything I am missing?

Just as an FYI, my QNAP Core updated without a hitch yesterday, and apart from issues related to the Roon Servers being overwhelmed it’s been running OK since.

For those where it’s not upgrading have you tried stopping and the restarting the Roon Core Service? Then trying to do the Update?

I’ve tried stop and start the service but no luck for the upgrade.

Hi All, I have a similar issue. I tried to update roon core in my QNAP TS 251+ with 8MB ram and I’m stuck in this window asking to set up the location for the roon data base. I assign the righ folder as usual and nothing happens… I have tried different folders, reinstall several times but it does not go beyond this screen:

I’m quite worried about the time i spend setting up roon every time i have any issue… on top of that I hope that by re-installing it it does not lose the data base and the info about preferences, favorites and so on because if i lose this info “again” I will seriously consider quitting roon…
Thanks to those who may help.

You should have a Data Base Back up somewhere. What specs are your QNAP? Have you checked against minimum requirements as this new version may be more processor intensive?

FYI, My TVS 471 i3 16 GB ram works perfect

How do you access your qnap administration? (By IP address, local hostname…)

Hi Christopher, I access through myqnapcloud in the browser. I’m not sure if this is what you are asking.
thanks for your help

Yes, I have the roonserver file in an SSD dedicated only to the roon database.

1 Like

Thanks, that made it simpler for me too.

Thanks for the info, @Angel_Vicente.
I will check, if there is an issue when accessing the Roon Server webpanel over myqnapcloud.
Could you also check, if the issue persists, if you access your QNAP by its local IP address?
You can find the qnap IP address either in an overview page of your router, or you can also check it in the network settings of the qnap device. (they often start with

The Roon Server webpanel checks the hostname in order to use QNAP FileStation API. I have not tested this with myqnapcloud, as I assumed, myqnapcloud will mostly be used as a service to access the qnap over internet…

I had that message too…and I proceeded. Mine did as advertised and stopped my Roon Server and then upgraded itself. I then re-opened the app and it showed the updated version.

I then launched my iPhone and PC client apps and they both worked. I updated my iPhone app before I attempted to launch Roon. On my PCs, the Roon client prompted me to complete the upgrade - which I did on each PC.

Always back up your database before any upgrade.

Thanks a lot @crieke for your help. By entering in the OS of the NAS through the IP address instead of through myqnapcloud it immediately worked perfectly !!!
You have been super helpful.
Have a great week end

1 Like

Thanks @Shane_White , this update work for me my QNAP TVS 682 NAS, every time after closing my Roon ready device my QNAP NAS will loose the audio device after another roon ready device power on, I have to restart the NAS Roon core to get back Roon ready device, & it’s quite troublesome for restarting the NAS, because it will take almost 15 minutes.