Roon 2.0 Crashing on Macmini

Don’t have a solution but reporting similar problem on iMAC (as core). Since the upgrade to Roon 2.0 it’s not useable. Multiple crashes a day, regardless if I’m playing music or not or if the Mac idle or not.

1 Like

Initially I thought it was random but I agree with your observations and can concur that I saw the same pattern. As of this morning I downgraded to 1.8 (Legacy) and thus far all going smooth.

1 Like

Hi there, is there an update on findings and resolution ?

Hey @Assaf_Kantorovichm,

I’ve split your posts into its own thread to help with visibility and engagement. Following up with this, we’ll need you to provide your full system setup:

Roon Core Machine

Include your operating system and machine info (Model, CPU, RAM)

Networking Gear & Setup Details

Your network gear (model of routers/switches) and if on WiFi/Ethernet

Connected Audio Devices

Specify what devices you’re using and their connection types, like USB/HDMI/Chromecast, etc.)

Number of Tracks in Library

Tell us how large your music library is, eg. “30,000 tracks”

Description of Issue

Tell us about the problem you’re having in as much detail as possible. Screenshots are always appreciated!

With that, if possible, can you please reproduce the crash a few times, and grab the date and time of the crash and share it here? From there, we’ll enable diagnostics on your account to take a closer look.

We’d like to get a copy of the full Mac OS crash report as well, if you could please upload that here.

I’ll be on standby for your reply :+1:

If by crash you mean Roon stops running my suggestion below likely won’t help but if Roon stops responding it could be related to your Mac power settings.
Roon 2.0 changed the way Roon interacts with Mac power settings.
Try changing your power settings as below and see if that helps.

1 Like

3 posts were merged into an existing topic: Roon 2.0 - Crashing on MacOS due to “.NET ThreadPool Worker” [Roon Investigating]

I am suffering the same crashing problem. I have tried your suggestion with the power setting with no luck. Roon core keep crashing every 2-3 hours

Hey @Assaf_Kantorovich,

Thanks for the info, and for sending over a set of logs. I’m seeing a massive amount of error logs in relation to Roon having issues connecting to a handful of your devices connected to your core. With this, I think we need to start from scratch and disconnect everything from your core, and first focus on your system output for your iMac.

With that, lets have you get a fresh database going as well:

  • Create a Backup of your current Roon database (or, if you have a recent backup that is fine)
  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “Roon” and “RAATServer”
  • Rename “Roon” to “Roon_old” and “RAATServer” to “RAATServer_old”
  • Reinstall Roon from our Downloads Page

Keep your core hardwired to your router, and keep everything else disconnected to your iMac for now. Once you’ve reopened Roon, let me know if things load properly. Only after that can we start to add each piece of your system back into the chain :+1:

Thank you for the speedy response and clear instructions. I have completed them all and also did a clean install from the link you have sent of Roon2.0.
Thus far I added only one device and will monitor performance for the rest of the day.
Will keep you posted on progres

Unfortunately after the clean install Roon core crashed again. I uploaded the log file (Dated Nov 22 at 18:34).

A post was split to a new topic: Mac Mini Late 2012 Roon 2.0 Crashing

Couple more crashes. I uploaded more log files. This never happened with Roon 1.8. Very frustrating and making roon not useable

Hey @Assaf_Kantorovich,

No need to upload logs for each crash, thank you for uploading what you have already though! We’ll need to investigate these logs with the team further.

With that, we will also need the full system-level crash logs, which you can upload here.

To confirm, you experienced the crash without any devices connected to your core?

Which device? If possible, please only run Roon playing audio from your system output to start.

One device connected (Streamer HIFI Rose RS150B).

I can monitor with only “system output” but is that mean I need to do again clean install ?

Hey @benjamin

I run all tested requested and posted the full log files at the link you have sent. Further more with no devices connected AND no music playing just Roon Core opened on my iMAC and same behavior; it crashes every ~3hours for the same error code .NET ThreadPool Worker
I’d appreciate your thoughts and hopefully resolution as it’s been now over a month that I can’t use ROON (since the 2.0 upgrade) . Thank you

Hey @Assaf_Kantorovich,

Apologies for the delay in following up. You are correct in that the existing thread you’ve shared does seem to be directly related to the issue you are also experiencing.

We have not yet been able to replicate this issue, and so we’re still in the earlier stages of pinning down what the cause might be. To better track this issue, I will merge this thread with the existing thread shared above. That way, whatever updates we’ll have to share, you will stay informed with other users also running into this issue.

I very much appreciate your patience while we continue to investigate :+1: