Roon 2.0 on 2010 Mac Mini - Linux?

This is only partly true. The fact that the drives are internal complicates things but it’s the journaling and ownership on the HFS+ that’s preventing rw permissions.

I used terminal on the Mac to remove journaling on my external music drive connected to my ubuntu mini which sorted the issue.

Oddly this morning ubuntu crashed and wouldn’t return, no EFI so I’m in the midst of troubleshooting. I like a puzzle and this is a good one. Not yet tearing my hair out.

Martin is a great asset here, He assisted me with my install.

Thanks BC, sorry to hear yours crashed though… did you have a backup of your Roon db? If so I would almost imagine it would be easier to reinstall than troubleshoot, at least that is my experience so far! Currently on Ubuntu install #3 in 24 hours :rofl:

How did you remove the journaling from your Mac? I also have a MacBook Air (newer model, M2) - wondering if I can connect in the good ‘ol target disk mode now that I’ve installed Ubuntu?

Thanks,
Michael

https://discussions.apple.com/thread/7789814

Super - thanks BC! Target disk mode didn’t work, but I was able to boot the Mac mini into internet recovery mode, open up a Terminal window and then use the following command

# diskutil disableJournal /Volumes/TheVolumeName

However… I was still not able to “Take Ownership” from the Disks application within Ubuntu. It gave me the error “Filesystem doesn’t support ownership (udisks-error-quark, 11)”.

Any ideas, is there a command line equivalent that would work?

Thanks,
Michael

I wonder did you do diskutil ls to identify the correct volume? Pretty sure DiskUtility can’t deal with ext4 volumes.

It’s still an HFS+ volume, so I used Diskutil (Mac) to disable journalling, but still don’t have rw access in Ubuntu

Update - sorted my HFS+ permissions issue using this, Samba also sorted now

@Martin_Webster only open topic is audio output - I am not able to get anything out of the HDMI output, only the internal Mac mini speaker :frowning:
I have created a support request here:

Thanks,
Michael

You may be well beyond this point, but you can run Roon 2.0 on older Intel Macs. You need to have a 16Gb USB drive and to run Open Core Legacy Patcher. I’m writing this on a late 2012 Mini running Roon 2.0. There’s a thread on this in the Tinkering forum.

The Mini runs Monterey (and Roon 2.0) nicely (I have an SSD in it though).

b

Hi Ben - believe that a 2012 Mac mini does support Monterey, but the 2010 model does not.
Or how to run open core legacy patcher?

So far everything runs perfectly in Ubuntu - apart from HDMI audio output, which I would like to have as I used the mini for multichannel audio to my DVR :frowning:

Thanks,
Michael

Mac Mini 2010 - Latest OS 10.13.6

i’m using an 2012 Mac Mini Server (latest OS 10.15.7) with roon 2.0 and it runs super! desktop sharing oder network functions in an “apple universe” is anything i would not miss :wink:

it’s very fast hardware (quad i7), has USB3.0 and you can upgrade RAM/SSD as you want (i have upgraded to 10GB and 128GB SSD for the system plus 4TB SSD for the music). But my “killer feature” is controlling roon with the Apple Remote or via the programmable remote control of my Arcam AVR.

it’s the most potential hardware for roon - quad i7 with 8GB RAM and a SSD will be traded for less than 250€ in germany. You get no NUC or anything else for this price! and apple hardware ist “HighEnd”, very silent (i hear the fan only when i import a lot of files) and has very low power consumption.

Multichannel sound via HDMI and Toslink (!!!) possible. But via Toslink not in HiRes, MC-HiRes needs more bandwidth than toslink can handle!

Hi Ben - thanks again for your post. Now somewhat belatedly installing Monterey via OpenCore Patcher as I write this. Roon worked smoothly on Ubuntu on my 2010 Mac Mini Server however I couldn’t get the HDMI audio to work (neither stereo nor Multichannel), which was an issue for my setup. So now trying Monterey as a last resort before either buying a NUC or Nucleus…. Fingers crossed it works!
(I especially resent the idea of buying a 7th gen NUC in Nucleus when the latest hardware release is 12th gen… it feels like buying old hardware for new prices!)

Hi again Ben - just wanted to say that it all worked well and I now have Monterey running smoothly on my 2010 Mac Mini Server (which I also fitted an SSD to run Roon from a while back) using open core patcher. Roon 2.0 appears to work smoothly (so far at least) and I finally have HDMI Multichannel audio to my DVR working again. So long, Linux :star_struck:

The only question I really have left is if there is any real sonic advantage in using Nucleus, given that it runs a “standard” 7th gen i3 board with presumably even less processing power than my 12 year old Mini (which is likely made up for by its extremely very slim OS)? Or is it mainly a convenience thing? There are surely no quality differences in terms of audio components, HDMI ports etc.

If not too late, I’d really give ROCK another shot… maybe I got lucky with my USB ethernet but try to find a used Cisco Linksys USB 2.0 Ethernet Adapter (M300) on ebay or something… it’s just so simple and easy to use and update.

I’m just really doubting that ROCK would support hdmi audio output on my mini, given that its GeForce graphics card is not supported for HDMI audio by the Nouveau drivers built into Linux (it took me quite a long time to find this out!)

https://nouveau.freedesktop.org/FeatureMatrix.html

“10 HDMI Audio only works for NVA3/A5/A8 (GT21x) GPUs. Some pre-NVA3 setups have been reported, but it’s no thanks to nouveau.”

Your opinion of your aged Mac mini is inflated. It is a little old Core2 Duo, man. Nucleus is no absolute powerhouse. It is not designed to be. But fact check here, its processor runs circles around that in your Mac mini.

https://www.cpubenchmark.net/compare/976vs2879/Intel-Core2-Duo-P8800-vs-Intel-i3-7100U

AJ

1 Like

I don’t think I would perceive an SQ difference, but it’s an easy way to keep the Mini out of landfill and undeniably cheap! Well done on the install.

B

1 Like

Thanks all - will stick with it until it gives up on me then, and upgrade to something newer when it has finally died. Maybe there will even be an updated Nucleus by then, to give me another 10-15 years :rofl:

Fact-check well noted - and appreciated as well :laughing:

I just put xubuntu on my 2010 Mac Mini this weekend and it was a pain. Had to TTY into it and reload nvidia drivers or I just got a black screen. That work around was flawless, but took me hours of frustration to find. Did 22.04 just load up without all the Nvidia issues?

Would you like me to load ROCK onto my 2010 Mac Mini and see if it the HDMI out works for multichannel? It is a bit of a process and requires multiple Mac Minis, but if it would help, I can load it up and test it out.

So both Ubuntu 22.04 and 20.04 installed and worked fine, in terms of graphics, using the standard Nouveau drivers - however no support for HDMI audio (a show stopper for me). I tried to install the proprietary Nvidia drivers, which wasn’t possible without rolling back to 20.02 and ended in an ugly mess (errors during install and not possible to boot without black screen crashes so I ended up just reinstalling). Think I reached 8 or 10 fresh installs of different Ubuntu releases before giving up. I didn’t try 22.10 though as this came out after I gave up.

But using open core patcher to install Monterey - that worked first time and so far seems to be working perfectly, and with beautiful Multichannel 24 bit 192kHz audio output (which I believe the newer Minis no longer support)

So to answer your question - no thanks, I am 99% confident that ROCK won’t support HDMI audio on the GeForce 320M graphics card. See also this self-solved support post for more details on why. Happy to be corrected if you know better though!! Also super happy with the support received from the tinkering community :slight_smile:

https://community.roonlabs.com/t/no-audio-output-from-2010-mac-mini-hdmi/215976

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.