Roon 2.0 on 2010 Mac Mini - Linux?

Hi there,

I am one of presumably many happy Roon users who has set up my old Mac mini server as a headless Roon server (also with HDMI for Multichannel in my case). Roon has always run really smoothly (I swapped out one of the 2 HDDs for an SSD for the OS + Roon database), however now I cannot upgrade to Roon 2.0 without purchasing new hardware. I’m not quite ready to shell out for a Nucleus, especially as it’s a few years old now in terms of technology but still the same price. And with the mac I can easily copy new music across to it over the network. Therefore I am now stuck with legacy roon 1.8 and no ARC.

Or am I? I was wondering if it is possible to install Linux on the 2010 Mac mini, if I understood the help pages correctly roon server runs on pretty much any Linux distribution since 2014. I am familiar and comfortable to use the command line including SSH, albeit no expert. This must be possible…

So my question, does anyone have any experience with this and can you recommend a Linux distribution that is also good with Multichannel hdmi output? This could actually end up being even better than my Mac as that often defaulted from 8ch 192k output back to 2ch….

Any advice appreciated :slight_smile:

Thanks,
Michael

p.s. is it actually possible to simply install ROCK / roon OS on an old Mac mini?

There are references in this forum regarding ROCK installs on Mac Minis but there are caveats.
I got close but it failed to connect to Ethernet even though I used a USB>Ethernet adapter as recommended in the forum. I gave up in frustration after a couple of hours.

Tried Linux Mint and then settled on Ubuntu with a minimal install. There are instructions for installing Roon Server (not Roon which does not have a linux counterpart) on the Roon download links page.

If all you need is the server it’s not very demanding of resources, though I’m running an i7 2012 Mini with 16GB of RAM, it’s far less taxing on the system than MacOS.

Super - thanks! I was also tending towards Ubuntu as it seems to be well maintained. Did you have to do anything special / drivers etc to make it work? And have you tried multichannel output? (I currently have the mini connected to my AVR via HDMI). Finally, is it easy to screenshare from (another) mac to Ubuntu?

Thanks,
Michael

If it helps I use a 2018 Optiplex 3050. It’s has an i5 6500 QC, 16GB, and a 128GB nvme. It cost me £49 ($50/$60) from a charity. I installed ROCK on it and within 10 minutes I was up and running with a core. It now runs headless 24/7. You could get a i7 version too, or even a little updated model (2019) for around £180.

These sort of machines (having M.2 nvme slots) are very popular as they are to easily available. Most business are now selling them due to a 5 year operating life, as these don’t support (officially) Windows 11.

Obviously there is no official supported. But, it’s a great little investment if you don’t have a lot of money. I got mine for convenience.

I just followed the instructions on the Roon linux page.

Don’t do multi channel as it’s in my basement next to my router and is just serving.
Screen sharing is possible with Team Viewer but I haven’t tried it. I have on old Dell Monitor connected to the mini if I need to administer it.

@Formula’s suggestion of a thrift shop computer with the specs to run ROCK is also worth consideration.

I’d definitely go with Ubuntu as any guides are more likely to remain relevant if fairly recent.

I have experience running Ubuntu 20.04 on my 2016 MacBook Pro; it should be relatively straightforward with your older Mac.

Happy to help if you try this.

Hi Martin,

Many thanks - having read many of your posts on this forum I’d be happy to have your support.

So I’ve managed to install Ubuntu 22.04 and got Roon server working. As my Mac Mini has two hard drives it is still able to access my media as HFS+ however I presume this is read only and I need to reformat as Ext4. Is there any way to do this without losing all the data? Takes a while to copy 500MB across via USB2 :slight_smile:

Another issue is that I can’t find a way to get the audio out from the Mac mini’s HDMI cable to the Denon AVR to work, there are lots of audio outputs recognised by Roon but the only one I can get to work is the internal speaker

Finally, I haven’t yet managed to get Samba and desktop sharing to work. Will try this again though, as I have an idea I know where I went wrong…

Thanks,
Michael

1 Like

This is only partly true. The fact that the drives are internal complicates things but it’s the journaling and ownership on the HFS+ that’s preventing rw permissions.

I used terminal on the Mac to remove journaling on my external music drive connected to my ubuntu mini which sorted the issue.

Oddly this morning ubuntu crashed and wouldn’t return, no EFI so I’m in the midst of troubleshooting. I like a puzzle and this is a good one. Not yet tearing my hair out.

Martin is a great asset here, He assisted me with my install.

Thanks BC, sorry to hear yours crashed though… did you have a backup of your Roon db? If so I would almost imagine it would be easier to reinstall than troubleshoot, at least that is my experience so far! Currently on Ubuntu install #3 in 24 hours :rofl:

How did you remove the journaling from your Mac? I also have a MacBook Air (newer model, M2) - wondering if I can connect in the good ‘ol target disk mode now that I’ve installed Ubuntu?

Thanks,
Michael

https://discussions.apple.com/thread/7789814

Super - thanks BC! Target disk mode didn’t work, but I was able to boot the Mac mini into internet recovery mode, open up a Terminal window and then use the following command

# diskutil disableJournal /Volumes/TheVolumeName

However… I was still not able to “Take Ownership” from the Disks application within Ubuntu. It gave me the error “Filesystem doesn’t support ownership (udisks-error-quark, 11)”.

Any ideas, is there a command line equivalent that would work?

Thanks,
Michael

I wonder did you do diskutil ls to identify the correct volume? Pretty sure DiskUtility can’t deal with ext4 volumes.

It’s still an HFS+ volume, so I used Diskutil (Mac) to disable journalling, but still don’t have rw access in Ubuntu

Update - sorted my HFS+ permissions issue using this, Samba also sorted now

@Martin_Webster only open topic is audio output - I am not able to get anything out of the HDMI output, only the internal Mac mini speaker :frowning:
I have created a support request here:

Thanks,
Michael

You may be well beyond this point, but you can run Roon 2.0 on older Intel Macs. You need to have a 16Gb USB drive and to run Open Core Legacy Patcher. I’m writing this on a late 2012 Mini running Roon 2.0. There’s a thread on this in the Tinkering forum.

The Mini runs Monterey (and Roon 2.0) nicely (I have an SSD in it though).

b

Hi Ben - believe that a 2012 Mac mini does support Monterey, but the 2010 model does not.
Or how to run open core legacy patcher?

So far everything runs perfectly in Ubuntu - apart from HDMI audio output, which I would like to have as I used the mini for multichannel audio to my DVR :frowning:

Thanks,
Michael

Mac Mini 2010 - Latest OS 10.13.6

i’m using an 2012 Mac Mini Server (latest OS 10.15.7) with roon 2.0 and it runs super! desktop sharing oder network functions in an “apple universe” is anything i would not miss :wink:

it’s very fast hardware (quad i7), has USB3.0 and you can upgrade RAM/SSD as you want (i have upgraded to 10GB and 128GB SSD for the system plus 4TB SSD for the music). But my “killer feature” is controlling roon with the Apple Remote or via the programmable remote control of my Arcam AVR.

it’s the most potential hardware for roon - quad i7 with 8GB RAM and a SSD will be traded for less than 250€ in germany. You get no NUC or anything else for this price! and apple hardware ist “HighEnd”, very silent (i hear the fan only when i import a lot of files) and has very low power consumption.

Multichannel sound via HDMI and Toslink (!!!) possible. But via Toslink not in HiRes, MC-HiRes needs more bandwidth than toslink can handle!