Roon 2.0 update order

Hi everybody

Excited to try out the new version.

Something’s not clear to me.
I’ve read elsewhere that some people that had updated their IOS device to the new version were unable to connect to their Nucleus still running 1.8 and so unable to update it to 2.0.

On the other hand the mail that I received today from Roon lab says update IOS first then your core.

So is it safe to update IOS first then your core?
Or should you update the core first?

1 Like

I tried to update Core first but process wouldn’t finish until I updated Roon Remote in IOS store. Once I updated Roon Remote, the Core completed its install of 2.0 and it all seems to be working now. I also downloaded ARC but haven’t tried it outside my home network yet.

1 Like

How do I update the core to 2.0?

I’m not getting any prompt and in the settings it says 1.8 is the latest version.

Wait till you get the prompt. It came up for me about 45 mins ago.

OTOH, I tried to update ROCK by using a 2.0 Remote and the process hung, until I rebooted ROCK.

Roon 2.0 has new OS version requirements. 10.15 on Mac and Windows 10. You would not get an update prompt if your system is not compatible.

1 Like

Ah I was fearing that. Am using an old laptop.

I have the same problem . Against my will Roon Remote in my Ipad updated to 2.0, and so I was forced to update mp PC with 2,0 . I restarted Roon on my PC and accepted to update, but it did not do it and is stuck on 1.8 “legacy”. Windows 10.Now I cannot use Roon at all. I am not very happy. Roon need to fox this broken software release immediately. I HATE ROON UPDATES , A MESS EVERY SINGLE TIME.

I am having the same problem. My Core is a Mac mini “core i5” 2.8 (Late 2014) running Mac OS 12.6 Monterey, yet I cannot update my Core to 2.0. It tells me 1.8 is the latest version. My iPhone and iPads have updated to 2.0 but will not let me access my Core as it’s still on 1.8.

I have restarted Roon, restarted the computer, and downloaded Roon for Mac OS, but I still have 1.8.

What’s the solution?

Start your own support thread so roon can see your issue. Fill in the requested system information

Thanks, the posting was a response to [Brian Luczkiewicz] Roon Labs: CTO above. I hope I’ll get a response.

So, to reply to my own question:

  • did disable auto update app on my iPad, not on my phone. So I had. 2 versions of Roon remote, 1,8 on LT ipad, 2,0 on my phone. Just to be sure…
  • connected to my core with my iPad (so 1,8), core said I had to update core and iPad.
  • updated core, then iPad , no issues, all went to 2.0 smoothly
  • has a small issue with the update of Roon remote on my MacBook, for an unknown reason it update from 1.8 to 1.8 legacy and so not compatible with my new core 2.0. Downloaded the 2.0 installer from the site and installed it. Small issue resolved.

Not a big deal.

So, all good

Cheers

David,

My Roon Server is on a 2012 Mini and it still works fine…that is if you like 2.0…My Core is on M1 Mac Mini so I can use convolutions, installed in Roon for Room Correction.

Did you resolve this? Roon Remote 2.0 is on the Apple App Store. You should turn off automatic updates in Roon and your iPhone if you don’t want to to update automatically.

Have you tried Roon Remote (Legacy) from the Apple App Store?

Earlier, I had searched the Apple App Store for the Roon app on my Mini. I downloaded that, but it is only 1.8. When I search for Roon on my iMac in the Apple App Store, NOTHING for Roon shows up for a download. So it seems that there is no Roon app for me to download from the App Store that is 2.0 ???

I do want to update my apps automatically, and I’ve never had any problem with that on my iPhone or my Roon Core (the Mac Mini). Updates have ALWAYS been seamless and never a problem. 2.0 seems to be unable to do that for some reason.

As noted above (sorry hope I didn’t reply to the wrong discussion) I could not find Roon 2.0 on the Apple App Store. It only downloaded 1.8 for me.

This is Roon Remote 2.0.01127 on the Apple App Store for your iPhone.

I am not looking for Roon 2.0 for my iPhone or iPad. I already have that.

I’m looking for Roon 2.0 for my Mac Mini (my Roon Core), which I cannot find anywhere - neither the Apple App Store, nor Roon’s own website. When I download the latest Mac version from Roon’s website, it only downloads 1.8 to my Roon Core/Mac Mini.

Download Links for Roon Core 2.0:

MacOS All-in-one / MacOS Remote

MacOS RoonServer

Windows All-in-one / Windows Remote

Windows RoonServer

2 Likes