Roon and CXN/DSD disappointment. DSD suggestions please

Hi Harry

That link goes nowhere , do I need to do it on the Core Machine ?

Sorry new to all this ??

Mike

Got it by IP address, sent the feedback reference 063c849fedf627af

Mike

Ok… but what is the exact problem? That’s still unclear to me. I see in the logs that you’ve got an M-DAC connected and not the CXN.

Could you explain what the issue is your exactly facing?

Roon cannot play DSD on CXN regardless of the set up. I have tried the “back” USB connection with my MAC directly connected and the required USB enabled on the CXN. It converts and doesn’t play DSD. Every other network configuration with the CXN (wireless or ethernet. Wired MACs) plays via air play and converts to 44/16. For me Roon has been a waste of money. I was seduced by the interface but I have free players on my MACs, phone and iPad that I can play my DSD files using an external HDD on my CXN.
My entire post has really just been about that point. The only reason I got Roon was it seemed better than other software even though that software played DSD from my MAC wireless into my network ethernet connected CXN. I assumed Roon, which seem well regarded by audiophiles would play DSD like the other software. Further evidence of how expensive Roon is for what it is .
I play mainly vinyl because it sound better than digital but I do enjoy the CXN and I like what I hear with DSD.
For me Roon has simply been a waste of money

ok. but to be clear:

It does play PCM right?

Sorry let me try and be clearer…

I have 2 DACs
Audiolab M-DAC (DAC and headphone amp)
Cambridge Audio CXN (DAC and Network Streamer)
Both are USB Capable, the CXN is network capable.

Neither are Roon Ready.

I use the CXN as an Airplay speaker with an ethernet cable , and I recently bought a RPi to feed the M-DAC USB directly as a Roon End Point with RoPieee.

The M-DAC on USB works fine but limits by design to 24/96, the CXN on USB will go to 24/192. So once I got everything working with the RPI I decided to try the RPI feeding the CXN so I cold get the 24/192

When I connect the RPi to the network and USB to the MDAC and the CXN to the network I see this
Capture

The RPI connecting the M-DAC and the Airplay of the CXN on its own network connection

When I now disconnect the USB to the M-DAC and connect the RPi USB to the CXN I don’t see the CXN as a “Networked” device as in the picture, I still see it in the Airplay section.

If I now disconnect the CXN from the network completely (wired and wireless) , I would expect to see the DAC portion as a standalone USB DAC as I originally saw the MDAC , I don’t . Roon simply doesn’t see it all

All config on the CXN is OK and all software and firmware is up to date.

The Logs I sent were sent with the CXN back in its Ethernet connected state as the image above.

I trust that’s confirmed what the status is.

I can send further logs with the CXN connected as a standalone DAC if that would help

Cheers

Mike

Ok, but it would help to ‘clear the picture’ if you leave out the M-DAC. This has nothing to do with the M-DAC, so the logs I had were not very useful.

So, with the M-DAC removed, make sure the CXN is connected over USB with the Pi (and turned on!) and with the ethernet connection removed from the CXN.

Also, give it a ‘hard’ poweroff/poweron cycle without the ethernet cable connected.
And just to be sure: it’s placed in USB 2 mode in the settings right?

After powering up, please send me again feedback.

Seems the problems is with Roon and there seems to be a lot of effort going into making hardware work with software that is simply not up to the job. I’m looking elsewhere which is a shame because the radio feature in Roon I really love.

Hi Mark

This getting worse !!

I used CA Connect for a limited time , it does A JOB but its a bit primitive compared to some software. I used JRiver and JRemote for many years and like you I was seduced by the UI of Roon. It has lots of good bits but quite a few shortcomings. I know its an expense but I keep both Jriver and Roon servers running and use them both depending on the requirement.

JRiver handles DSD and SACD ISO natively and controlled by JRemote work 100% with the CXN.

I am sure the powers that be don’t like such discussions on this forum so if you want to chat pls PM me

Mike

He guys, I’m willing to help out here, but simply claiming that ‘Roon’s not up to the job’ is not helping. At all.
There’s a ton of hardware that works out of the box, and including stuff like DSD.

Let me know if you need any help.

Thanks,

Ok

I have disconnected CXN from network, hard power up I am seeing USB Audio 192 KHz on the screen which implies USB Class 2 is OK

I have sent logs 06ace4f2f0bcc5f1

this is what I see in Roon

ie no Networked devices

Cheers

Mike

I’m still confused. I still see the M-DAC in the logs. Is that still connected to the Pi?
Can you please unplug the M-DAC completely and have only the CXN connected?

Sorry Harry bit of frustration creeping in

I am a Roon convert but some aspects are on the Coming Soon list that raise a level of frustration.

DSD to me isn’t one of them I am more concerned around software issues like classical handling. Hardware has not been a problem until this CXN issue and even that is able to be worked around

Sorry if we are stirring stuff up unnecessarily

Cheers

Mike

I’ll do it again but the log was taken when it was completely unplugged. Let me repeat the whole exercise, back in a mo

Do you have an USB hub in between by any chance?

Right

MDAC completely unplugged from RPI, still powered up but NO Connections to anywhere

CXN Restarted from scratch , error messages saying No Network (as expected)

a903f77cafb36688

Still shows USB Audio 192.0 khz
Roon Audio Settings still shows o networked devices as per previous picture

Cheers

Mike

No its the RPi , direct cable to either device, same cable and different cables show no difference.

There is a network switch but the Rpi Conncection has been the same all along

Mike

Ok. I’ve found the problem. The CXN is not properly registered on the Pi (Linux) as a working Audio device. So it’s not Roon’s fault that it does not recognize the device.

Now the weird thing is: with all USB attached devices that are being used by happy Roon customers, this is the first time that I’ve seen something like this.

I’m gonna do some digging around why this is happening…

Just for for the test: can you disable the ‘USB 2’ option in the CXN and try again? It’s clear that that’s not what you want because the documentation says the max sample rate goes down, but at least we can see if that setting causes the problem.

Thanks,

1 Like

Will do back in mo

1 Like

OK

c0c7e0be5fb6aded

CXN Reset to USB Class 1
CXN Hard Restart

Shows USB Audio 96Khz as expected

Mike