Roon Android - Stops Playing as Background App

Roon Core Machine

Laptop: Dell Inspiron 3502 . Intel Pentium 1.1 Ghz. 4GB RAM. Windows 10.
Phone: Samsung Galaxy A10e. Android 11. 2GB RAM.

Networking Gear & Setup Details

Netgear Nighthawk.

Connected Audio Devices

Ethernet cable from router to core. Wifi to phone.

Number of Tracks in Library

280 albums on Roon. No other music.

Description of Issue

Roon stops when it’s a background app on my phone playing as a endpoint from laptop (core). For example, it stops when I web browse to read the Roon community boards and listen to my headphones in the background. The exact timing and frequency of the stoppage varies, but it happens every playing session and prevents me from listening to Roon on my headphones. Sometimes I must restart Roon a dozen times a hour. The app works fine as a remote, just not as a player.

I have investigated this issue for weeks and I believe the solution may have to do with how Roon interacts with the “Allow Background Activity” toggle switch in my phone settings. By default Roon has turned it on and grayed it out. See screen clip below. This would seen just fine, however and most pertinently, I can replicate and resolve my issue by toggling the switch off and on respectively using the Qobuz app.

Background
I have unoptimized the Roon app, turned off all battery saving etc. Because I can successfully stream Qobuz and Spotify as a background app I don’t believe it’s an issue with Android 11 or my kernel architecture.

My phone speed tests at upwards of 175mb/s. I turned off Smart Connect on the Nighthawk. I don’t get slow or lost connection warnings. The app simply stops. In sum I don’t believe it’s a network issue.

Roon stops regardless if I am listening with wired, blue tooth or regular phone speakers.

I don’t believe it’s a phone RAM issue because I have minimized running background apps to only those required by the OS. I am using 1.3 of my 2GBs. Clearing my cache, which provides about 200-300mb more temporarily has no affect on Roon stopping. As many apps as possible are asleep.

It’s not any particular browser because I have tried three. Even using the settings app has caused Roon to stop. Reinstalling the Roon app had no affect. “Keeping screen on” in Roon has no affect. Cleaning Library had no affect.

Thank you for your prompt attention to this issue.

Thanks for the detailed report, @Ryan_Carlson. Can you reproduce this issue once more and, when happens, let us know the time and what track was playing? We’ll enable diagnostics and take a look at what is happening during that time. Thanks!

Hello. Thanks for getting back to me.
I replicated the issue at 11:10am PST with the song Rewind That by Christian Scott on the album Rewind That.

I triggered the stoppage 1:26 into the song by opening up several tabs in Chrome and performing searches.

Thanks, @Ryan_Carlson. I’ve enabled diagnostics and will take a look once the report comes in.

Hi, I wanted to relay that today while on the internet on my phone and listening to Qobuz, Qobuz stopped. Just like Roon, just once however over the course of an hour. I also detected 2 very brief pauses, but Qobuz kept playing. So I think it’s fair to say this isn’t a Roon problem alone, but the stoppage occurs more often (20x).

I also have a sense that the problem grew with the addition of more albums to my virtual Roon library.

I wonder if having 2GB RAM phone, but with about 700mb unused is the source of the problem. Using Chrome eats up 300MB+, so then I have 400mb theoretically left including any the phone must hold in reserve. Roon appears to use 27mb.

Hi Dylan, I’m curious when the diagnostic reading is scheduled to be reviewed. Thanks!

Hi Dylan, I purchased a Pixel 2 and “fixed” the problem. Same Android 11, same network etc. If you could offer any insight into why my Samsung A10 wouldn’t work I’d appreciate it. From what I can tell it meet the hardware requirements and is a common device. Perhaps based on Roon’s Pixel 2 recommendation specific hardware requirements could be formalized and published.

@dylan
Hi Dylan,
I’m experiencing a similar problem on my Android device (OnePlus Nord): when the Roon app goes to the background I hear a stutter about every 5 seconds. Background can mean working in another app or when the screen goes off. It goes OK when I set the setting to enabled in Roon to keep the screen on.
I’m listening to tracks on Qobuz.
Hope you can identify a cause for this?

Cheers,
Joost

Hi, sorry to hear that you have this problem. I found it really frustrating. My problem, I think, was RAM, but your phone has plenty. Your phone has Open GL3.2, so you are good there too.

Try this: go into into Settings<Apps<Roon<Battery and make sure “allow background activity” is ON. Also in Roon app settings go to “Optimize battery Usage” and make sure that is OFF (not optimized).

If neither of those help, try turning off general battery saving mode and clear memory cache.

The basic goal is to give Roon as much resources as possible. I didn’t have an issue when I only had 100 Roon albums in my virtual library, but at around 300, I ran into this problem.

These are all the things I’ve read could solve your problem. None of them worked for me so I bought a used Pixel 2 and it works well. I just use it as a remote not as a phone. Not ideal, but I need a functioning remote.

Hi Ryan,
Thank you for your reply. I went looking for the two app settings you describe. The first option “allow background activity” I can not find but then I discovered that Battery Optimization was still on for the app… :pensive: I was certain I disabled that when I installed the app a long time ago…
So, turned it off and now it is playing well.

Thank you and I am going to be ashamed in a corner now.

Ha, great and happy listening.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.